Won't boot with Clevo AMD 4700U laptop

I use the Clevo’s 4700U laptop.

I just boot using latest EndeavourOS ISO with Ventoy, but boot fails.
It stucks on ‘triggering uevents’ message.

I added ‘loglevel=7’ to boot option, and got this message

fb0: switching to amdgpu from efi vga

So, I added ‘nomodeset radeon.modeset=0’ to boot option, and It passed prior stuck point.
It boot successfully, but failed to initialize Xorg because it can’t detect any monitors.
Xorg loops and showing same error message, and no GUI. I turned off laptop at this point.

I blacklisted ‘radeon’ module but failed Xorg again.

I gave up about resolve this issue, but report this for sharing.

It’s the best way to NOT have Xorg working, as explained at Archwiki.
You could have tried:

radeon.modeset=1

amdgpu cannot work with nomodeset .

No-one can profit from your report, since you don’t share system specifications. :man_shrugging:

radeon.modeset=1 is default boot option of EndeavourOS.
so I disabled it for ‘test’.

And, I already noticed I use Clevo’s 4700U Laptop. Nothing special.
What specification? Model number? External GPU?

Well, Clevo is OEM Laptop barebone manufacturer. And they have just single 4700U model and many OEM variants.
My variant also have Internal GPU like many other Laptops, so I didn’t write that.

This is correct and Ryzen 4700U or any other Ryzen 5500, or 5700 etc with internal GPU should work too using amdgpu. The issue has to be some other reason and you have provided no logs and little information. Saying it doesn’t boot isn’t really very helpful.

I don’t know how to get system logs from boot failed device…
I will take an picture and attach that when if I have some times.

There is a way:
https://wiki.archlinux.org/title/Systemd/Journal#Specify_a_different_journal_to_view

So, you are using the shared video graphics on the Ryzen CPU and not a dedicated AMD GPU?
I have a laptop with the Ryzen 4600U, no dedicated GPU and the live iso boots and installs without issue.

Yes.

Thank you. I will try.

Is there any chance you can create the live ISO with another method instead of using ventoy? It’s worth a try because there is no reason for Ryzen 4700U not to boot on the EOS ISO. Ran into this before.

@choryuidentify
You could try some more kernel parameters such as

iommu=off

Sorry, I have no time to try obtain logs (I only have Windows now)
I just take a picture real quick. I added ‘loglevel=7’ on default Live boot.
20220209_092102

It didn’t work…

Could you try maybe this one then? I’m trying to think what might work.

amdgpu.dpm=0

It didn’t work too. same message…

Did you try this kernel parameter?

pci=noats
2 Likes

Wow! It works perfectly!
Thank you very much for your help!

Glad that it worked. Sometimes it’s hard to know. I’m no expert and i try to guess what the hardware issue is so i think about it a lot. I’m happy when a user doesn’t give up and tries my ideas. Sometimes i don’t get it but a lot of times i have success. Unfortunately not always! :wink:

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.