Wlan isn't working

Running ping gives Temporary failure in name resolution. While checking status of dhcpcd.service it gives result in the images. I don’t know what the problem is. Network Manager shows it is connected to a wifi network by the way. How to troubleshoot ?


It seems that you get an IPv6 allocation from your service provider, but you don’t have a suitable router for it? What DNS server are you using? Can you ping IP addresses but not hosts? Can’t you test it on a direct wired connection?

Thanks for the reply. I’ve found out it is a hardware problem.

Specifically, which part was faulty?

I think it is network adapter. When I turn off the wifi and want to start again, in taskbar of xfce it says device not ready. Using the command nmcli radio wifi on also, wifi doesn’t turn on and remains completely unresponsive due to which I’ve to reboot the system. I’ve also tried other distribution’s live usb and that’s the same case.

could be also an issue when dualbooting and windows is not set to not use fastboot… leaving devices in a locked state…

And you can use nm-applet on xfce4 setup in the panel where you can setup network settings.

Network manager automatically registered on ISP’s DNS but I changed that to which worked without any hindrance for days. Suddenly, wifi is connected but doesn’t transfer data. Wired Connection works perfectly fine. Seconds after booting up, ping gives:

PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=56 time=10.4 ms
64 bytes from icmp_seq=2 ttl=56 time=5.36 ms
64 bytes from icmp_seq=3 ttl=56 time=8.10 ms
64 bytes from icmp_seq=4 ttl=56 time=9.13 ms
64 bytes from icmp_seq=5 ttl=56 time=6.83 ms
64 bytes from icmp_seq=6 ttl=56 time=8.86 ms
64 bytes from icmp_seq=7 ttl=56 time=6.59 ms
64 bytes from icmp_seq=8 ttl=56 time=15.0 ms
--- ping statistics ---
8 packets transmitted, 8 received, 0% packet loss, time 7011ms
rtt min/avg/max/mdev = 5.362/8.792/15.043/2.802 ms

After sometime ping gives:

PING ( 56(84) bytes of data.
From icmp_seq=1 Destination Host Unreachable
From icmp_seq=2 Destination Host Unreachable
From icmp_seq=3 Destination Host Unreachable
From icmp_seq=4 Destination Host Unreachable
From icmp_seq=5 Destination Host Unreachable
From icmp_seq=6 Destination Host Unreachable
From icmp_seq=7 Destination Host Unreachable
--- ping statistics ---
8 packets transmitted, 0 received, +7 errors, 100% packet loss, time 7141ms
pipe 3

Did you try disabling ipv6?

Thank you for the suggestion. I don’t dualboot with windows.

I tried that but didn’t work.

What is the adapter?

inxi -Na

Device-2: Intel Wireless 3165 driver: iwlwifi

This adapter is fairly dated and does suffer some issues with bluetooth coexistence, platform noise, power management and channel frequency. It is also may not be supported by the latest firmware. So you may need to downgrade that.

It may be easier to to just replace it with a known working trouble free adapter that works on Arch linux.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.