Wireplumber bluetooth headset mic issue

Hi there,

So having just run the update which switches to wireplumber from pipewire-media-session. I use a boltune bt-bh010 headset and when I tested the mic after update, it sounded awful, all crackly. I use it in Headset head unit (HSP/HFP codec mSBC) mode, using plasma and bluedevil. AFAIK that type of sound can be caused by a bitrate sampling mismatch, but looking in


I cannot find the option to change bitrate except for the A2DP codec, which I believe is for the speaker function, not the mic. I have not yet disabled any codecs in this file, which the file itself recommends as a workaround for some devices.

If wireplumber is just broken for my application, perhaps someone could point me to a resource for removing the wireplumber dependencies so I can switch back to pipewire-media-session?

Inxi output

Kernel: 5.18.9-arch1-1 arch: x86_64 bits: 64 Desktop: KDE Plasma v: 5.25.2
Distro: EndeavourOS
Type: Desktop Mobo: Micro-Star model: MPG Z390I GAMING EDGE AC (MS-7C04)
v: 1.0 serial: UEFI: American Megatrends v: 1.80
date: 05/25/2020
Info: 6-core model: Intel Core i5-9400F bits: 64 type: MCP cache:
L2: 1.5 MiB
Speed (MHz): avg: 2833 min/max: 800/4100 cores: 1: 3099 2: 2443 3: 2359
4: 3414 5: 3279 6: 2408
Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT]
driver: amdgpu v: kernel
Display: wayland server: X.org v: with: Xwayland v: 22.1.2
compositor: kwin_wayland driver: X: loaded: amdgpu gpu: amdgpu
resolution: 1920x1080
renderer: AMD Radeon RX 5700 XT (navi10 LLVM 14.0.6 DRM 3.46 5.18.9-arch1-1)
v: 4.6 Mesa 22.1.3
Device-1: Intel Cannon Lake PCH cAVS driver: snd_hda_intel
Device-2: AMD Navi 10 HDMI Audio driver: snd_hda_intel
Sound Server-1: ALSA v: k5.18.9-arch1-1 running: yes
Sound Server-2: PipeWire v: 0.3.53 running: yes
Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi
IF: wlan0 state: down mac: 46:69:9c:20:32:ab
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
driver: r8169
IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: 2c:f0:5d:07:37:66
Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
driver: btusb
Report: rfkill ID: hci0 state: up address: see --recommends
Local Storage: total: 1.84 TiB used: 687.33 GiB (36.5%)
ID-1: /dev/nvme0n1 vendor: A-Data model: SX8200PNP size: 953.87 GiB
ID-2: /dev/sda vendor: SanDisk model: SDSSDH3 1T00 size: 931.51 GiB
ID-1: / size: 953.57 GiB used: 77.1 GiB (8.1%) fs: btrfs
dev: /dev/nvme0n1p2
ID-2: /boot/efi size: 299.4 MiB used: 576 KiB (0.2%) fs: vfat
dev: /dev/nvme0n1p1
ID-3: /home size: 953.57 GiB used: 77.1 GiB (8.1%) fs: btrfs
dev: /dev/nvme0n1p2
ID-4: /var/log size: 953.57 GiB used: 77.1 GiB (8.1%) fs: btrfs
dev: /dev/nvme0n1p2
Alert: No swap data was found.
System Temperatures: cpu: 30.0 C pch: 44.0 C mobo: N/A gpu: amdgpu
temp: 40.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 11
Processes: 237 Uptime: 37m Memory: 15.56 GiB used: 2.65 GiB (17.1%)
Shell: Bash inxi: 3.3.19

I am afraid I can’t be of much help to resolve the Bluetooth issue.

You could replace wireplumber with pipewire-media-session but since wireplumber is the recommended session manager for pipewire, I doubt this would be a viable option in the long run.

  • PipeWire Media Session — A very simple session manager that caters to some basic desktop use cases. It was mostly implemented for testing and as an example for building new session managers.

https://gitlab.freedesktop.org/pipewire/media-session || pipewire-media-session


So when you will have exhausted all the options to solve your initial issue and still want to replace wireplumber:

sudo pacman -Rdd wireplumber 
sudo pacman -S pipewire-media-session

:warning: Please do some research of your own. Choosing to follow the suggestions from a random virtual person, the responsibility is all yours :wink:


i do not think that it is possible to have BT using high quality input in Headset-Mode.
Is this not an issue for a long time on linux?

Thanks for this advice. Youtube sound on Firefox stopped working for me after Wireplumber update and replacing it with pipewire-media-session is the only way I’ve found so far to get it back.

1 Like

Did you also restart PipeWire/Wireplumber or log out/in or reboot?

1 Like

Yea I restarted wireplumber, though I don’t think I tried a hard reboot last night, so it’s possible it’ll get working again tonight, which would be joyful.

I do know Bluetooth headsets are a longtime Linux issue , but I’ve not had any issues with this one on pulseaudio or pipewire under pipewire-media-session.

When I have more time at the weekend I may try editing the config file I looked at before to remove some of the connection options it allows.

1 Like

What version of pipewire are you on? Im not using BT but have had many issues with 0.3.53 and rolled back to 0.3.49 (im on fedora so thats my last version before 53)

I for instance couldnt have applications playing sounds at the same time without the audio crackling and slowing down.

EDIT: just noticed youre on 53, try rolling back to older pipewire to see if it helps

1 Like

Hey, many thanks indeed - this fixed it.

As I am a noob, I like to record other details for future noobs like me to have the whole picture in the future. So here goes

  • I first tried switching back to pipewire-media-session as suggested by @pebcak above; this didn’t resolve the issue
  • I then tried x11 - I default to plasma on wayland now - as I’ve heard of weird wayland-pipewire interactions
  • Following Echoa’s suggestion, I downgraded. Because the EOS team are great, they give you the downgrade tool, so I just ran the command below and selected the last version I could be sure worked from the menu it brings up in terminal.
  • I rebooted and - there you go - working bluetooth again

sudo downgrade pipewire

Broken pipewire 1:0.3.53-3. Version that worked for me 1:03.52-2.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.