Wireplumber and pipewire-media-session are in conflict

Hello all

I am a Linux newbie.

Been on Windows all my life from Win 95 to Win 11.

I usually manage to get by solving my Linux issues such as upgrading and basic configuration.

I am however, unable to resolve the ‘wireplumber and pipewire-media-session are in conflict’

I have removed pipewire from my system; even run the command to disable it.

I am still unable to update my system with the error:

error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: wireplumber and pipewire-media-session are in conflict

How can I resolve this please?

Thank you and kind regards


You should no longer need pipewire-media-session, go ahead and remove it and install wireplumber in it’s place. It’s newer and going to be the solution for pipewire going forward.

As an aside, why remove pipewire from your machine? It’s definitely an improvement over pulse at this point. Far more usability at this point, and IMO the bluetooth performance is leagues better.


Hello timiller76

Thank you for your response.

My issues lies in the fact that there is a conflict being displayed even after I removed ‘pipewire’ - well at least I believe I did.

I still cannot upgrade my system which is the main issue for me.

How do I check that I have indeed removed pipewire and then resolved the upgrade system issue?

Thank you

If your intention is to switch away from pipewire to pulseaudio, please have a look at:


Thank you pebcak

Actually I still have audit on my system.

My main issue is the system is refusing to update to the next version of Endeavour.

:: Starting full system upgrade…
resolving dependencies…
looking for conflicting packages…
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: wireplumber and pipewire-media-session are in conflict

There is no next version of :enos:. This is a rolling release distribution.
What command are you using to update??

Can you try these commands?

sudo pacman -Rs pipewire-media-session
sudo pacman -Syu wireplumber

Welcome to the forum @prime :enos_flag: :partying_face:

Hello sradjoker

Thank you for your reply.

I am using the following command to update: sudo pacman - Syu

When I run the first command you suggested I get the following error:

error: failed to prepare transaction (could not satisfy dependencies)
:: removing pipewire-media-session breaks dependency ‘pipewire-session-manager’ required by gst-plugin-pipewire
:: removing pipewire-media-session breaks dependency ‘pipewire-session-manager’ required by pipewire-alsa
:: removing pipewire-media-session breaks dependency ‘pipewire-session-manager’ required by pipewire-jack
:: removing pipewire-media-session breaks dependency ‘pipewire-session-manager’ required by pipewire-pulse

Thank you mate :slight_smile:

Learning new things as I go along :rocket:

Can you try

sudo pacman -S wireplumber

and then answer with y when the prompt asks you to replace pipewire-media-session.

How so?

You still have all the pipewire packages in your system :wink:

Yup this time round it removed pipewire

:: Processing package changes…
Removed /etc/systemd/user/pipewire.service.wants/pipewire-media-session.service.
Removed /etc/systemd/user/pipewire-session-manager.service.
(1/1) removing pipewire-media-session [-----------------------------------------------------------] 100%
(1/2) installing lua [-----------------------------------------------------------] 100%
(2/2) installing wireplumber [-----------------------------------------------------------] 100%
Created symlink /etc/systemd/user/pipewire-session-manager.service → /usr/lib/systemd/user/wireplumber.service.
Created symlink /etc/systemd/user/pipewire.service.wants/wireplumber.service → /usr/lib/systemd/user/wireplumber.service.
Optional dependencies for wireplumber
wireplumber-docs: Documentation
:: Running post-transaction hooks…
(1/1) Arming ConditionNeedsUpdate…

My audio is still working

Thank you so much everyone for your kind help

next I will try to run : sudo pacman -Syu

This didn’t remove pipewire, pipewire is still there.
This removed pipewire-media-session that is a session manager for pipewire.
You have replaced that with wireplumber that is supposed to be a better session manager for pipewire.

Also welcome to purple side of linux!!
:enos_flag: :rocketa_purple:

1 Like

After all these years with Windows I see that I have much to learn.

Still thank you to you all for taking the time to help and guide me :rocket:

Am running Endeavour on an Indeal Core Duo and it’s running smoothly no lag - so can’t complain - it’s a fantastic os and a great community :slight_smile:

hi @prime,

welcome to the purple universe :enos: :enos_flag: :penguin_face: :rocketa_purple:

Can I ask one more thing please ?

When I upgrade I get the following:

:: Import PGP key 0F65C7D881506130, “Maxime Gauduin alucryd@archlinux.org”? [Y/n]

Who do I need the PGP key, doe the system not generate a PGP key automatically? why does it have to use the one from Maxime ?

Thank you

Hello pycrk

Thank you - so many things to learn

1 Like

try this command to refresh your keyring:

sudo pacman -Sy archlinux-keyring endeavouros-keyring && sudo pacman -Su

Mark the post that solved your issue as the solution so that it helps other users having same issue.

The keys you are talking about are keys of the arch packagers who are packaging the packages we use.