Wireless (USB) headphones not working

Hey, I bought a " PDP AIRLITE PRO" headset, marketed as compatible with playstation’s and Windows 10.

USB is detected but it doesn’t show up in blueman manager.

the device shows up as the following when i run ‘lsusb’:

*ID 0e6f:0234 Logic3 PDPGaming LVL50 Wireless for XboxOne (Dongle)*

When i connect the headphones with usb cable they show up as:

*ID 0e6f:0233 Logic3 PDPGaming LVL50 Wireless for XboxOne (Headset)*

After searching, i found that ‘xone’ or ‘xpadneo’ could be possible solutions, however, when i install xone, the light on the usb adapter or ‘dongle’ doesn’t turn on so the headphones can’t even connect to that when its plugged in and i have had no luck with xpadneo either.

I already tested the headphones on Windows 10 and they do work.
I have also tried different ports and a USB 2.0 hub as well.

Any help is greatly appreciated, thank you very much.

Used the git clone method install of xone instead of AUR and it is now working

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.