Wired networking module not loading

Loving EndeavorOS, been running it for many months, but after an upgrade I noticed I didn’t have wired networking anymore. I took a look, it was easy enough to bring Wi-fi back up via the UI so I could look up solutions, and figured out I could bring wired networking back up with:

sudo modprobe r8169

Once that worked, I added a file:


Which just contains the module name:


However, this does not come up on boot, I have to run:

sudo modprobe r8169

To get wired networking working again. Any idea what I’m doing wrong, or why this won’t load? Thanks!


Probably you should simply uninstall package r8168.

1 Like

You don’t need to do that - the kernel will automatically load modules for detected hardware unless they are blacklisted.

And reboot. :smile:

Just out of curiosity, would adding r8169 to MODULES=() in mkinitcpio.conf work as well?

This worked! Thank you! How did you know that was installed, and was that just interfering with r8169 being loaded?

Thank you, I took that file out too, and it works without it now!

He’s a wizard! It’s also a semi regular quirk of some computers. But, I’m still going with a wizard. . .



1 Like

The ”magic” is it is installed by default. :wink:
There are many threads about this issue here, feel free to look at them.
Some machines work with r8168, some with r8169, and some with either of them.

Excellent, thank you - I only searched for networking issues, should have searched by the module name

That Magic by @manuel!

1 Like

Perfect! Sorry I didn’t see that before, great docs!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.