Wired Network Settings missing after update

Recently performed full system upgrage, and upon reboot, found my Wired network was no longer available. After searching through system settings, I could not find any settings for configuring a wired network; and following some other forum topics, I uninstalled package r8169. After a reboot, settings were still not present, and was curious as to what was causing the issue.

Kernel version is linux-zen 5.17.1.zen1-1
DE is Gnome (also tested on Gnome on Xorg with same issue)
Motherboard is a Gigabyte B550 Aorus Master, in case hardware is relevant to the issue.

Any insight to the issue would be appreciated.

I don’t know of a package for r8169 - what did you remove?

Which settings?

What does inxi -Faz show?

Does ip a show a local IP address?

Several other forum posts all led back to the same topic, and several linked here.

I do not see any configuration menus for wired internet at all, and prior to this issue were normally accessed through the system settings under the network tab. At the moment, all I see are options to set up VPNs, as well as some network proxy settings, neither of which I use.

inxi -Faz gives me a bash error that the command is not found. Whatever that command is from, it is not installed.

ip a shows two connections, one labeled lo and one labeled wlan0. Both show an IP address, but the lo address shows a scope of “host”, which I assume is local.

Wifi still works.

I assume they can’t have linked to this thread, though?

I think inxi is installed by default in EnOS.

Every DE has things in a different place, so this isn’t massively useful without further context. However,

This means your Ethernet network adapter - whatever it is - is not being detected at all by the system.

More information is needed about your system, specifically the network adapter you have. inxi -Naz will provide information about detected adapters, though it might not be illuminating in this case.

You should also try some different kernels, e.g. linux-lts will provide kernel 5.15 and help isolate the problem to a regression in kernel 5.17.

Sorry, the page I was referencing was hyperlinked to the text “here”. Hyperlink led to this wiki page: https://discovery.endeavouros.com/network/r8168-workaround/2021/03/

I don’t have inxi installed. Guess it’s not default, I don’t ever remember uninstalling it

Is the fact I specified I use Gnome not enough? Not being sarcastic, genuine question, as my ability to properly provide information is super important to resolving issues.

I’ll try swapping kernels, and see if that resolves the issues.

1 Like

Ick, the hyperlink didn’t show up… the colour is not the most obvious… :pensive:

It should be, but I’d actually need to read that in your OP. My fault. :bowing_man:

Switching between these to see if one or the other works is a case of

modprobe -r r8168
modprobe r8169

or the reverse. However, given r8169 has been improving and is the default for recent kernels this is the better option (especially if it worked before), so if it has broken in 5.17.1 then it’s likely to be a regression (and so will be fixed at some point) and 5.15 will be the workaround until then.


Sweet, I’ll give these a try and if I nail it I’ll mark the solution. Otherwise, I’ll post results.

Yep, swapping kernels to linux-lts 5.15 worked, wired connection is back. Regression on 5.17.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.