Wired connection not working

I recently made a thread about a different issue, the suggested solution was to downgrade, which I did and the previous problem was solved.
Should this be of any help here’s the link to the thread:

However, starting yesterday I’ve had connection issues that were occasionally solved by a reboot.
After the downgrade it seems to be worse, and the connection is missing each time I reboot.

I’m now connected with a wireless usb pen, which works, but it’s not optimal, I’d rather use my wired connection.

In the thread linked above I was told to check the page: https://discovery.endeavouros.com/network/r8168-workaround/2021/03/

I did and uninstalled r8168, which sadly didn’t help.

Should it be useful, here’s the output for

inxi -anN

and for

systemctl status NetworkManager
 raccoon@trash  ~  inxi -anN                      
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI X570-A PRO driver: r8169 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 27:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: enp39s0 state: up speed: 1000 Mbps duplex: full
    mac: 2c:f0:5d:21:e1:4e
  Device-2: D-Link System DWA-140 RangeBooster N Adapter(rev.B2) [Ralink
    type: USB driver: rt2800usb bus-ID: 3-1:4 chip-ID: 07d1:3c0a class-ID: 0000
    serial: 1.0
  IF: wlan0 state: up mac: 1c:af:f7:75:86:f0
  Device-3: SteelSeries ApS Arctis 7 wireless adapter type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 5-3.4:5 chip-ID: 1038:1260
    class-ID: 0300
 raccoon@trash  ~  systemctl status NetworkManager
● NetworkManager.service - Network Manager
     Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; vendor preset: disabled)
    Drop-In: /usr/lib/systemd/system/NetworkManager.service.d
     Active: active (running) since Mon 2022-05-30 14:39:14 CEST; 14min ago
       Docs: man:NetworkManager(8)
   Main PID: 837 (NetworkManager)
      Tasks: 3 (limit: 38440)
     Memory: 13.5M
        CPU: 1.721s
     CGroup: /system.slice/NetworkManager.service
             └─837 /usr/bin/NetworkManager --no-daemon

mag 30 14:47:29 trash NetworkManager[837]: <info>  [1653914849.9426] device (enp39s0): state change: deactivating -> disconnected (reason 'user-requested', sys-iface-state: 'managed')
mag 30 14:47:29 trash NetworkManager[837]: <info>  [1653914849.9649] dhcp4 (enp39s0): canceled DHCP transaction
mag 30 14:47:29 trash NetworkManager[837]: <info>  [1653914849.9649] dhcp4 (enp39s0): activation: beginning transaction (timeout in 45 seconds)
mag 30 14:47:29 trash NetworkManager[837]: <info>  [1653914849.9649] dhcp4 (enp39s0): state changed no lease
mag 30 14:47:29 trash NetworkManager[837]: <info>  [1653914849.9650] dhcp6 (enp39s0): canceled DHCP transaction
mag 30 14:47:29 trash NetworkManager[837]: <info>  [1653914849.9650] dhcp6 (enp39s0): activation: beginning transaction (timeout in 45 seconds)
mag 30 14:47:29 trash NetworkManager[837]: <info>  [1653914849.9650] dhcp6 (enp39s0): state changed no lease
mag 30 14:47:29 trash NetworkManager[837]: <info>  [1653914849.9712] policy: set 'Martin Router King' (wlan0) as default for IPv4 routing and DNS
mag 30 14:47:29 trash NetworkManager[837]: <info>  [1653914849.9715] audit: op="statistics" interface="enp39s0" ifindex=2 args="0" pid=1445 uid=1000 result="success"
mag 30 14:47:34 trash NetworkManager[837]: <info>  [1653914854.3800] audit: op="statistics" interface="wlan0" ifindex=3 args="0" pid=1445 uid=1000 result="success"

1 Like

Just a comment on this:

since your capture card works on both the LTS and the latest 5.17 but not your wired connection on either of them, I would think t’s better to stay on the LTS and troubleshoot the issue. In this way you are at least on a kernel with the latest security updates.

The idea of downgradig to the latest 5.17 was initially intended for testing to see if everything was working there.

Understood, I’ll do that then!
Thank you.

1 Like

Going back to LTS MIGHT have fixed the connection…
I will keep the thread open for now because it wouldn’t be the first time that it looks there’s connection until it doesn’t.

1 Like

Sounds promising!
Hopefully it will stay like that.

What’s the difference with lts? And should I uninstall it at some point?

LTS= Long Term Support
The others are built on the latest stable release upstream

See here:


You could keep it as backup for situation like this when there are issues with the latest releases.
LTS is tested and trusted and you know it works.

Thanks for your help, this was educational, despite the annoyance of not having things working for a bunch of hours I’m still happy cause I got to learn a little bit of stuff.

1 Like

You may have already tried this, but just to be sure:
there are two driver alternatives to the 8168 card. To test them you can either

  • install package r8168, reboot and test
  • uninstall package r8168, reboot and test

For the LTS kernel test, replace r8168 with r8168-lts.

If neither works, then problem must be elsewhere.

Thank you Manuel, for now things seem to work but should they stop I’ll try to follow your tip.

1 Like

If the problem, as per the title of the topic, is solved to your satisfaction, please consider checking the solution box under the appropriate post pointing out the solution.

In this way, the forum software will regard the thread as solved and other users with similar issue will find the solution more easily.


In addition, the development can use a working solution to make the install experience better for all of us.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.