Wine/Proton not using GPU properly

Distro: EndeavourOS
Version: KDE Plasma version: 6.0.4
Kernel Version: 6.9.1-arch1-1 (64 bit)
Graphics Platform: X11
Graphics Processor: NVIDIA GeForce GT 730/PCIe/SSE2
Graphics driver: 470.239.06 -2
Display Manager: gdm
CUDA Version: 11.4
Vulkan version: 1.3.279
issue: Graphics card not being utilized/not working with using Proton/GEProton/Wine
Detail: Games such as Minecraft and Ultrakill (native to linux) are able to use GPU properly and without issues, games such as Need For Speed: Hot Pursuit, Need For Speed: The Run, Crysis 3, Deamon X Machina either can not utilize GPU and default to integrated graphics or do not run at all, here are the results:
Minecraft: Runs just fine, 80-100% GPU utilization (linux native)
Ultrakill: Runs just fine, 60-90% GPU utilization (linux native)
Need For Speed (both games): both run on wine however GPU remains unused/not utilized on default wine, does not run at all on proton, error states that it failed to initialize display adapter
Crysis 3: run on wine however GPU unused, fails to start graphics device/display adapter on proton
Deamon X Machina: runs on wine however crashes when GPU is needed, fails to start graphics device/display adapter on proton
conclusion/TL;DR: Proton can not access GPU for some reason
(sorry i know it might not be entirely an EndeavourOS issue but i am a newbie to linux)

Can you send the results of this command please?

pacman -Qs vulkan

Welcome! :smile:

Please show also the output of

inxi -Gza

Also, this may be of use:

lspci -k | grep -A 2 -E "(VGA|3D)"

local/lib32-nvidia-470xx-utils 470.239.06-1 NVIDIA drivers utilities (32-bit) local/lib32-vulkan-icd-loader 1.3.279-1 Vulkan Installable Client Driver (ICD) Loader (32-bit) local/nvidia-470xx-utils 470.239.06-2 NVIDIA drivers utilities local/qt6-shadertools 6.7.1-1 (qt6) Provides functionality for the shader pipeline that allows Qt Quick to operate on Vulkan, Metal, and Direct3D, in addition to OpenGL local/spirv-tools 2024.1-1 (vulkan-devel) API and commands for processing SPIR-V modules local/vulkan-headers 1:1.3.285-1 (vulkan-devel) Vulkan header files local/vulkan-icd-loader 1.3.285-1 Vulkan Installable Client Driver (ICD) Loader local/vulkan-tools 1.3.269-1 (vulkan-devel) Vulkan Utilities and Tools

here you go :smiley:

Device-1: NVIDIA GK208B [GeForce GT 730] vendor: Gigabyte driver: nvidia
    v: 470.239.06 alternate: nouveau,nvidia_drm non-free: series: 470.xx+
    status: legacy-active (EOL~2024-09-xx) arch: Kepler code: GKxxx
    process: TSMC 28nm built: 2012-2018 pcie: gen: 2 speed: 5 GT/s lanes: 8
    bus-ID: 01:00.0 chip-ID: 10de:1287 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 24.1.0
    compositor: kwin_x11 driver: X: loaded: N/A failed: nvidia gpu: nvidia
    note: X driver n/a, try sudo/root display-ID: :1 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 92 s-size: 530x301mm (20.87x11.85")
    s-diag: 610mm (24")
  Monitor-1: Unknown-1 mapped: HDMI-0 res: 1920x1080 dpi: 93
    size: 527x296mm (20.75x11.65") modes: 800x600
  API: EGL v: 1.5 hw: drv: nvidia platforms: device: 0 drv: nvidia device: 2
    drv: swrast gbm: drv: kms_swrast surfaceless: drv: swrast x11: drv: nvidia
    inactive: wayland,device-1
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 470.239.06
    glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce GT 730/PCIe/SSE2
    memory: 1.95 GiB
  API: Vulkan v: 1.3.279 layers: 5 device: 0 type: discrete-gpu
    name: NVIDIA GeForce GT 730 driver: nvidia v: 470.239.06
    device-ID: 10de:1287 surfaces: xcb,xlib

Thank you for the welcome :D, here you go

        Subsystem: Gigabyte Technology Co., Ltd Device 379b
        Kernel driver in use: nvidia```

:D

also an update on what i found out:
turns out it wasnt exactly a IGPU problem, IGPU was not being used as it was does not support Vulkan and is disabled in the bios, the problem is with dxvk, the GPU is too old for the dxvk Proton uses so i switched to a older version of Proton (Proton 7) and turns out some games worked (Games like Need for Speed Hot Pursuit, Need For Speed The Run, Crysis) but somehow other games (Games like Monster Hunter World, Daemon X Machina) dont even run tho they both directx11?

Have you tried using this launch command?

PROTON_USE_WINED3D=1 %command%

This translates the games calls into OpenGL instead of Vulkan, it could work but at the cost of lost performance.

Edited your inxi output to make it more readable, hope that was OK.

1 Like

Hey Thanks for the suggestion, unfortunately it proven to be unfruitful in both Proton 7 and 9, and tested in two different games with the same result

Thanks :D, its my first time here so getting the hang of it

1 Like

Fixed issue:
By using lutris, i set the dxvk version to the one usable to my gpu then created a new wine prefix.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.