Wine - GoPlayAlong 4 crashes in Endeavor but runs on my Fedora computer


use GoPlayAlong 4 on Fedora with Wine (fresh install it works)

It’s guitar tab software that allows you to attatch MP3,and other formats so you can play the actual song

but with Endeavor it crashes whenever I load an MP3 to a track

without a MP3 it doesn’t crash but just plays MIDI


  1. System information:
  2. Wine build: wine-5.22 (Staging)
  3. Platform: i386
  4. Version: Windows Server 2008 (I use this same as Fedora since program won’t display under others)
  5. Host system: Linux
  6. Host version: 5.9.14-arch1-1

So I believe it’s an issue loading MP3 (codec issue? or with directx?)

here’s the terminal output when running and adding an MP3:

here’s the log after crashing

Doesn’t look like it’s mp3 related actually…

Hey, few of question before we start:

  1. Do you still have working version of Wine in Fedora, which was it?
  2. Have you used any winetricks?
  3. Do you use default wineprefix ~/.wine ?

Windows Server 2008 (I use this same as Fedora since program won’t display under others)

That is SUPER unusual, i’m pretty sure that shouldn’t be the case, because there are a lot of stuff which can happen if you set anything other than Win7.

1 Like
  1. Yes, it still works on my Fedora workstation - I can hop on at any time and post logs or whatever needed.

It worked with a fresh install of Fedora and Wine (pretty much out of the box)

Fedora now updated to version 6 of Wine and it still works

  1. Winetricks is default and I tried replicating what I had on my Fedora workstation

  2. Yes, default but 32-bit version of Wine

and for using Windows server 2008 mode

The app doesn’t display prorperly - I think it uses directx (or mono/gecko)

It just displays black

I use the same settings on both Endeavour and Fedora

I"m going to do more troubleshooting today

I think it’s either a codec issue or a directx

when I load a guitar tab without a mp3 - it runs flawlessly

but once a mp3 is loaded with the guitar tab - it then crashes

I’d advice to try create system-independent x64 prefix with win7 settings to debug, but if everything is like you said…

Make sure you have those packages installed and try again:


P.S. btw, how exactly do you load .mp3? With some dialog or by drag & drop?
Some Wine programs have hard time with drag & drop

I’ll try x64 wine bottle

Win7 doesn’t display the program - it will have a black screen

I installed both packages and still the same issue

The program comes with a tab with a song already attached

It also crashes

when adding a song - it uses a file browser but I can add the song with no issues

here’s the working fedora output

If you want to try on your build then the program can be downloaded here

There’s a song included which crashes in my Endeavour build

I removed wine-staging - deleted .wine

installed again and used 64bit

still crashes with this output

I"m comparing packages between my fedora computer and my Endeavour laptop (Macbook)

Ok so i’ve created x64 prefix (non system) with (non system wine) 5.20-staging
Indeed UI works only with Windows 2008, which again is SUPER weird.

So i’ve loaded demo track, pressed play, it plays…Anything additional i should check out?

My output is pretty clean:

[2020-12-27 21:13:38] [info] App starting (4.4.4)
[2020-12-27 21:13:38] [info] Windows_NT (6.0.6002), 8x Intel(R) Core(TM) i7-4770K CPU @ 3.50GHz, 31GB Memory
Node: 12.4.0 Electron: 6.0.10 Chrome: 76.0.3809.146 v8: 7.6.303.31-electron.0 uv: 1.29.1
[2020-12-27 21:13:40] [info] Checking for update
[2020-12-27 21:13:40] [info] Update for version 4.4.4 is not available (latest version: 4.4.4, downgrade is disallowed).
[2020-12-27 21:13:51] [info] [song actions] loading song Demo Track
[mp3 @ 0B72E340] Estimating duration from bitrate, this may be inaccurate
[2020-12-27 21:13:51] [info] Opening audio output at 44100 Hz
[2020-12-27 21:13:51] [info] Set audio device to
[2020-12-27 21:13:51] [info] Using  audio driver
[mp3 @ 0B73E080] Estimating duration from bitrate, this may be inaccurate

Also i use jack system-wide to play audio, and have realtime-related stuff enabled, that shouldn’t matter for such error like you have i guess, but still worth mentioning…

P.S. ooof, it’s Electron / Chrome based :face_vomiting:

I use jack on Fedora as well

I’ve converted a MP3 file to .wav

it works on fedora with .wav

and here’s output with in Endv with .wav

I’ve been working on this for 4+ hours

I need a break


Well, since it works for me it’s certainly not Fedora vs Arch problem at all.

Not sure what exactly is wrong for you, but i think you should try non-system prefix with non-system Wine version, for example POL build

You can use this simple scripts from my gaming guide (read 0. Prepare to 4. Install game) to get how to.

And launch program via exactly same script as just change the .exe for suitable path (you must launch such .exe through this non-system Wine version of WINELOADER and WINESERVER).

Sorry for inconvenience with this simple scripts, but it’s fastest way to get clean result for now.

Otherwise just try to install clean EnOS in VM and try to figure out what’s going on…
I don’t see anything obvious why it shouldn’t work for you as it works for me :confused:

I’ll follow your guide in a couple of hours and see the results

I"ll also try clean EnOS build

what wine cfg setttings are you using?
is it latest winestaging?
are you running wine in win7 64bit?

Are you running Nvidia?

I’m on a Macbook Air 2012 so it’s intel only based
not sure if that makes a difference

All answered here, but i guess you can use latest available version too, it’s just what i had laying around for quick test:

Yep, proprietary driver

That probably may be the case (if by Intel you mean GPU / drivers), not entirely sure… :thinking:

Btw, ain’t there something FOSS for tabs available without Wine?

building a fresh install of EnOS now in a VM

and for the FOSS tab

I want to play the actual audio/song and not the midi

Goplayalong allows me to do this

I haven’t found any other tab software that does that

1 Like

fixed it by

removed wine-staging

deleting .wine

installed wine (non-staging)

it now runs with mp3s, wavs

Guess Arch/EnoS version of wine stagging is behind Fedora and has issues with the app

well, that was most the day wasted troublshooting that issue …ahah

1 Like

Doubt it, Arch should be ahead of Fedora.

My advice would be to never use system wine directly, it certainly will be problem in a future, if you need something stable - use portable wine / prefix with versions that you know work (you still technically will need wine / wine-staging / winetricks packages installed on system, but they won’t affect your prefix / productivity anyhow and you won’t be locked to specific version (latest != best))