Need help urgently,
First post so expect some @$@!!
Luv endeavearos, but having headaches with windscribe VPN.
It has ruined my wired connection. I can only get the internet by using public dns. When I use windscribe and do an test I get ip for windscribe and a heap of dns servers that are not associated to windscribe. Then when I disconnect I get " ‘busctl’ exited with status 1". Sick of googling for answers. have symlink /run/systemd/resolve/resolv.conf /etc/resolv.conf . No ides how to manually setup a wired connection. Have tried multiple times, to no avail. Sure others out there have had problems setting up windscribe. Maybe someone can steer me in right direction.

Hello @Dasher56
What is saved in the /etc/resolv.conf file? Maybe it has saved the ip addresses of the connections for windscribe.

cat /etc/resolv.conf

Thanks for a reply. As I mentioned, I have to use opendns servers to get online.
ip addr
lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: enp2s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
link/ether fc:aa:14:4f:cf:ea brd ff:ff:ff:ff:ff:ff
inet brd scope global dynamic noprefixroute enp2s0
valid_lft 86154sec preferred_lft 86154sec
inet6 fe80::261:708e:56ff:a56a/64 scope link noprefixroute
valid_lft forever preferred_lft forever.
After startup “cat /etc/resolve-.conf” > nameserver

After connecting with windscribe > nameserver
Why is windscribe is at the bottom ?” says ip address is windscribe. 50 dns servers (all opendns)
After disconnecting from windscribe "/etc/resolv.conf " > nameserver

With the messqage “[2777]: ‘busctl’ exited with status 1”

I use Windscribe for browsers only, using extensions. And I don’t experience any problems.
I don’t quite understand the need to use a system-level VPN…

1 Like

What extension is this and which browser do you use it on?
Edit: I see the extension for Windscribe on Firefox.

1 Like

There are extensions for both Firefox and Chrome

1 Like

"/etc/systemd/resolved.conf.d/dns_servers.conf "
“sudo start systemd-resolved”
“sudo enable systemd-resolved”
Then in terminal
"sudo rm /etc/resolv.conf ;sudo ln -sf /run/systemd/resolve/resolv.conf /etc/resolv.conf ;sudo systemctl restart --now systemd-resolved’” says windscribe “AOK”

Still get ‘busctl’ exited with status 1" when disconnecting windscribe. "sudo systemctl restart --now systemd-resolved’

By the way “Always have windscribe extension on Firefox and Brave Browsers”

Not sure if this is the correct answer.

sudo rm /etc/resolv.conf

sudo ln -s /var/run/NetworkManager/resolv.conf /etc/resolv.conf

Edit & Set your own public DNS

sudo systemctl start systemd-resolved.service

windscribe connect

ricklimux: Thank you for the idea. I tried with Networkmanager “resolv.conf” before I had created those files I mentioned earlier, with no luck. It certainly does not give that "busctl status 1 " warning anymore when disconnecting from windscribe and reverts back to public DNS. Everything seems ok now. Grateful for the input. No idea how to mark “SOLVED”

Just click on the … dots near reply and it opens to show a solution box to check. :wink: