Windows updates made my systemd boot disappear

Idk how, but I might have to reinstall endeavour… SystemD boot doesn’t appear anymore, here’s what happened

As soon as it got installed I tried to restart, hit f11 so the boot manager would show the other SSD, booted into KDE and it was giving me the error: incorrect password(Idk why, but anyway, maybe in a hurry I wrote the password badly and can’t remember it), I unplugged the external SSD where endeavour os is installed, I check the windows 10 and it works, I plug the SSD back in and all I see is the boot manager of windows TWICE, once from the SSD where Linux should be at and once from the SSD where windows is at

I try the Linux SSD and in windows it boots

So I guess it was windows updates that messed up the systemD since I booted it up with Ethernet in and it did windows updates

Should I try reinstalling it with Grub instead of systemD and maybe gnome instead of KDE? I’m a bit confused , especially cuz it should have worked, but it didn’t, good part is that window 10 is intact on the Intel SSD, but Linux not as much on the Kingston SSD :confused:

Can someone experien to my dumb head what happened?
I feel kinda sad :sob:

1 Like

This happened because Windoze replaced the linux bootloader with its own bloody bootloader during the Windoze update.

What you need to do is boot into a live environment, chroot, and then reinstall the linux bootloader (systemd-boot).

You can find instructions on how to install systemd-boot here:

Instructions on how to chroot can be found here:

1 Like

How do I deal with a forgotten password?

1 Like

You mean you forgot the root password? Or the password for your user account?

1 Like

I don’t remember any of them

1 Like

If you have one user account (whose password you do remember) that is capable of using sudo (e.g: it is inside the wheel group), then you can change the root password with sudo passwd root. If you have no access to such a user account, then you have to:

  1. Boot using the live ISO
  2. Mount your root partition
  3. Chroot
  4. Then use the passwd command to set the password for the root account.
1 Like

Isn’t it a better option to reinstall using the same partitions ? It seems like a lot of work

1 Like

If I were in your position, I would perform a clean re-install as well. I would also avoid dual-booting windoze with Linux if possible. If you need to use Windows (and if your hardware is powerful enough), just install Linux and then run Windows in a virtual machine.

If you insist on dual-booting, I recommend checking your system’s BIOS. Some BIOSes provide an option to protect the system’s boot partition, which will prevent windows from overwriting it the next time you upgrade.


I’m curious if the fact that I unplugged the external SSD didn’t mess up the bootloader(it was unplugged after everything was installed and laptop was stopped) , does maybe Linux have something like fastboot from windows that would mess up the bootloader (sys d boot) ?

I’m asking cuz I’m still learning about it

Cuz technically windows didn’t have access to the SSD when updating(I guess)


Boot up your live usb.
With your external ssd connected, post the output of the following commands:

sudo parted -l
1 Like

I suspect he is sharing the /efi just came back to ask that lol.


Hmm, I’ll try to reinstall I guess it’s no use right now to dig into that since I don’t have the password, right?

You could set new passwords in chroot as mentioned above.
But it’s your system so it’s your call.


What do these do ?

The first command lists out all your partitions. The second one will list out some data and information about your system’s boot options. efibootmgr, as its name suggests, is a command-line utility to help you manage your UEFI Boot Manager configs.

1 Like

although at one level it may be simpler to reinstall, going through the hassle of learning how, and gaining the confidence to fix these types of errors are invaluable. And in the end if you can’t fix it, you can always reinstall so all you lose is a bit of time. It’s happened to me only once, and having to lookup how to fix it was (and if I had to do it again I would have to look it up all over again) was a good learning experience. The beauty of Linux, unlike windows, is that almost any error can be recovered from without having to pull the nuclear option which is so prevalent in windows.

1 Like

I reinstalled, it works now


:grin: in the end as long as it works that’s all that matters. Glad you got it working

1 Like