Windows/EOS dual boot and clock

Hello all, my first post here.
After installing EOS alongside my windows and every time i boot to EOS first, then windows 10, windows 10 clock is always 2 hours behind my GMT time (Helsinki, Finland). So i have to go to windows clock settings and switch off “set the time automatically” and switch back it to ON to get the proper time.
Any idea what might cause this odd behavior?

Anyways, i REALLY like EOS so far. Boot time is like 2 sec, while 12 sec to windows 10.
And im using JBL Quantum Duo speakers via USB connection and EOS detected them properly. For some reason (or is it just me), MP3/FLAC sounds a lot better, clearer with EOS than Windows(used foobar, resonic, aimp). Maybe JBL drivers for Windows are not so good?

Welcome! That’s an old problem… Don’t know if that method fixes it, but here is an article delineating the problem.

Making Windows use UTC time like Linux is probably not the best option. You can edit the registry to make Windows use UTC time, but this could potentially cause more problems than just making Linux use local time.

https://www.howtogeek.com/323390/how-to-fix-windows-and-linux-showing-different-times-when-dual-booting/

To dual boot with Windows it is recommended to configure Windows to use UTC, rather than Linux to use localtime. (Windows by default uses localtime [1].)

https://wiki.archlinux.org/title/Clock#UTC_in_Microsoft_Windows

Contradictory recommendations?
:thinking:

1 Like

On my system with dual boot i set local rtc to 1

timedatectl status
System clock synchronized: yes
              NTP service: active
          RTC in local TZ: yes

ntp service needs to running

timedatectl set-local-rtc 1

In windows i make sure is set to correct time and date and time zone etc.
Then set in linux with above command. I’m not sure how it works in other time zones. Or setting Windows with UTC. I have never done that? For me this is how it works properly otherwise when you boot into windows the time is out by 4 hours.

Hi, is this a some sort of a bug:
When i try to set GMT time, in drop down menu i gaves me an options;
GMT
GMT+0
GMT-0
GMT0
If i try to manually type GMT+2 it does not accept it.
What is the difference between GMT+0, GMT-0 and GMT0?

I just created an entry in Windows registry like Arch wiki says to do so…

https://wiki.archlinux.org/title/System_time#UTC_in_Microsoft_Windows

1 Like