Windows Dual boot


I am using Debian on my other PC where I am doing Dualboot with Win10 and Grub(Customizer).

Now with EndOS - can I go the same way or is there any similar simple-to-use way to make Dualboot?
System is GPT.

You don’t need grub customizer. You should be able to install and replace the partition that you have debian installed on with EndeavourOS if that is what you want? Just select grub in the installer as it defaults to systemd.

no, i havn’t Debian on this PC, just WIn10.
Along with this I want to have EndOS.

1 Like

If you only have the Windows partition on your disk and there is no free space, shrink the partition as much as you want under Windows, then by booting your computer with EndeavorOS live cd or usb, you can use Gparted to create a Linux partition and a swap partition in the freed space , but you can also entrust this to the installer. If you have free space, you can immediately create a Linux and a swap partition using Gparted. If you already have a partition other than Windows, use Gparted to divide it into a Linux partition and a swap partition. By default, the installer offers the sytemd-boot bootloader, but you can also choose EFI grub. The installer installs basic things, after which you can customize the system to your liking. I recommend that you also select the LTS kernel for installation, because if for some reason the system does not start with the stable kernel, you can also start it with the LTS kernel, which can help in many cases.

Disable bitlocker, shrink your Windows partition within Windows, install as normal.

ok, I did so.

I have 50% Windows and 50% EndOS now, but the PC does only boot one of them, as I can select from Boot menu: “Windows Boot manager” or “endevouros”.

In my other PC with GRUB, I had one entry “Grub Boot manager”, which gave a menu which OS to boot.

What does this show? Post the link.

cat /etc/default/grub | eos-sendlog
1 Like


You need to edit the default grub file and uncomment


You can use nano to edit the file.

sudo nano /etc/default/grub

uncomment the line i reference above (remove the #)

Then to save the file and exit.

ctrl + o then enter to save
ctrl + x to exit nano

Then update grub with

sudo grub-mkconfig -o /boot/grub/grub.cfg



Did you install with grub? Or did you install it with systemd-boot?

super. Thank you very much - have nice xmas !

1 Like

You too! Merry Christmas :christmas_tree:

had you problems with bitlocker?

I personally didn’t but I know Bitlocker with TPM can ask recovery key if Windows isn’t booted the way BitLocker wants and that’s annoying.

no, had no problems

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.