Windows dual boot refind issue

Hey Everyone

i have a dual boot setup : window and endeavour os

i also had rEFInd installed through endeavour and i regularly used to boot through rEFINd

Yesterday I did some window update and when i reboot it, both endeavour and rEFINd is gone. Both aren’t in UEFI boot entry as well.

I have also tried to disable secure boot and reboot but still rEFINd won’t fired up.

I tried Chroot but it didn’t worked.

Please Help. I really need my data which i stored on Linux.

Looks like you have to go through the whole process of installing refind again from scratch, without deleting anything!

From there, after success, a dual boot setup without refind might be recommended:

1 Like

Assuming you have tried the above from the EnOS’ live usb, you could boot it up again and run the following commands and post the output of:

sudo parted -l

efibootmgr -v

Copy the terminal output as text, paste it into your reply, highlight it and press Ctrl-E to format.

4 Likes

It sounds to me as if your NVRAM on the computer was cleared by Windows - so in that case nothings has probably been lost or misplaced. 2 ways that comer to mind for fixing include live ISO boot, arch-chroot, and rerun refind-install - or using efibootmgr to add an entry for rEFInd. Let us know what’s next!

4 Likes

wdym by without deleting anything?

sudo parted -l

[liveuser@eos-2022.04.08 ~]$ sudo parted -l
Model: ATA ST1000LM049-2GH1 (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name                  Flags
 1      1049kB  983GB   983GB   ntfs         Basic data partition  msftdata
 2      983GB   1000GB  16.9GB  ntfs         Basic data partition  msftdata


Model: Kingston DataTraveler 3.0 (scsi)
Disk /dev/sdb: 15.7GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name     Flags
 1      1049kB  15.7GB  15.7GB               Ventoy   msftdata
 2      15.7GB  15.7GB  33.6MB  fat16        VTOYEFI  hidden, msftdata


Model: WD Blue SN570 500GB (nvme)
Disk /dev/nvme0n1: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size    File system     Name                          Flags
 1      1049kB  106MB  105MB   fat32           EFI system partition          boot, esp
 2      106MB   123MB  16.8MB                  Microsoft reserved partition  msftres
 3      123MB   285GB  285GB   ntfs            Basic data partition          msftdata
 5      285GB   285GB  537MB   fat32                                         boot, esp
 6      285GB   287GB  2147MB  linux-swap(v1)                                swap
 7      287GB   322GB  34.4GB  btrfs
 8      322GB   499GB  178GB   btrfs
 4      499GB   500GB  633MB   ntfs                                          hidden, diag

efibootmgr -v

[liveuser@eos-2022.04.08 ~]$ efibootmgr -v
BootCurrent: 0006
Timeout: 1 seconds
BootOrder: 0005,0002,0006,0003,0004
Boot0002* UEFI OS	HD(5,GPT,5bca990b-0329-2c4d-b744-be172428f372,0x21257800,0x100000)/File(\EFI\BOOT\BOOTX64.EFI)..BO
Boot0003* UEFI: PXE IP4 Killer E2600 Gigabit Ethernet Controller	PciRoot(0x0)/Pci(0x1,0x4)/Pci(0x0,0x0)/MAC(00d8618a7956,0)/IPv4(0.0.0.00.0.0.0,0,0)..BO
Boot0004* UEFI: PXE IP6 Killer E2600 Gigabit Ethernet Controller	PciRoot(0x0)/Pci(0x1,0x4)/Pci(0x0,0x0)/MAC(00d8618a7956,0)/IPv6([::]:<->[::]:,0,0)..BO
Boot0005* Windows Boot Manager	HD(1,GPT,2484615f-459d-4ed7-9e15-c59233dd358f,0x800,0x32000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)..BO
Boot0006* UEFI: KingstonDataTraveler 3.0PMAP, Partition 2	PciRoot(0x0)/Pci(0x8,0x1)/Pci(0x0,0x3)/USB(6,0)/HD(2,GPT,3db86df5-0f45-4c91-b1ed-884eb08a603d,0x1d3a1d8,0x10000)..BO
[liveuser@eos-2022.04.08 ~]$
2 Likes

I see two FAT32 partitions on your disk.
Did you create a second EFI System Partition for your EnOS?

5      285GB   285GB  537MB   fat32          boot, esp

You could try this boot entry

Boot0002* UEFI OS HD(5,GPT,5bca990b-0329-2c4d-b744-be172428f372,0x21257800,0x100000)/File(\EFI\BOOT\BOOTX64.EFI)..BO

and see if it works.

In the live session open a terminal and run:

sudo efibootmgr -o 0002,0005,0006,0003,0004

Reboot.

2 Likes

so I tried doing chroot and re-run refind-install it worked

In my trial, I actually forgot to repair the grub after chroot. Only after your suggestion, did I suddenly remember it. (dumb me :dizzy_face: :woozy_face:)

so what did I do?

  1. boot into the live iso environment
  2. arch-chroot
  3. repair the grub
  4. reinstalled refind
  5. change the boot order
  6. bingo

Thank you @pebcak @freebird54 @ivanhoe for your help :star_struck:.

1 Like

Actually, that UEFI os aka 0002 is not the thing we’re looking for. IDK what it is but it is not that ;-;

1 Like

Alright then.
Glad you got it resolved!

Please mark @freebird54’s post as the solution of the topic for it to close.

1 Like

done.

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.