Windows boot manager not showing in grub menu

I used to have only endeavouros in my ssd. yesterday i installed(tried to dual boot) windows. After that, the grub stopped appearing during boot time, and windows would boot by default. so i reinstalled endeavouros today(hoping the grub will show “windows boot manager”). The problem is: the grub doesnot include option to boot into windows. Please help me to include windows booting option in the grub. I’m quite new in linux world.


I followed the arch-wiki and commentated the line :

Next, I ran the command

sudo fdisk -l
[sudo] password for rammani: 
Disk /dev/sda: 931.51 GiB, 1000204886016 bytes, 1953525168 sectors
Disk model: TOSHIBA MQ04ABF1
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 49B7D199-7B50-AE4B-AAE8-B09743610AC6

Device     Start       End   Sectors  Size Type
/dev/sda1   2048 629147647 629145600  300G Microsoft bas

Disk /dev/sdb: 476.94 GiB, 512110190592 bytes, 1000215216 sectors
Disk model: Netac SSD 512GB 
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 7F046D57-484B-48FF-8D37-3E5BD8C847CA

Device         Start        End   Sectors   Size Type
/dev/sdb1       2048  209717247 209715200   100G Microso
/dev/sdb2  209717248  314574847 104857600    50G Microso
/dev/sdb3  314574848  315803647   1228800   600M Microso
/dev/sdb4  315803648  317032447   1228800   600M EFI Sys
/dev/sdb5  333809664  535136255 201326592    96G Linux f
/dev/sdb6  317032448  333809663  16777216     8G Linux s
/dev/sdb7  535136256 1000215182 465078927 221.8G Linux

Partition table entries are not in disk order.

then ran the command
sudo mount /dev/sdb3 /mnt

then I ran the command

>>>sudo grub-mkconfig -o /boot/grub/grub.cfg             
Generating grub configuration file ...
Found background: /usr/share/endeavouros/splash.png
Found linux image: /boot/vmlinuz-linux-zen
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux-zen.img
Found fallback initrd image(s) in /boot:  intel-ucode.img initramfs-linux-zen-fallback.img
Found linux image: /boot/vmlinuz-linux
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux.img
Found fallback initrd image(s) in /boot:  intel-ucode.img initramfs-linux-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Adding boot menu entry for UEFI Firmware Settings ...

But still I donot see the windows boot manager in grub menu.

For better readability, please edit your post and format the output text.

Highlight the terminal output text and press Ctrl-E.

Also, please indicate which partitions belong to your Windows install.
Is it installed in BIOS/Legacy or UEFI mode?

i have formatted the text.
the partition sdb1 with 100G contains windows, sdb2 is a common partition to be used in both windows and linux.
In bios, I see the mode as UEFI, so it must have been installed in UEFI mode

When I try to mount sdb1(windows partition), i get error as:

sudo mount /dev/sdb1 /mnt
Windows is hibernated, refused to mount.
Falling back to read-only mount because the NTFS partition is in an
unsafe state. Please resume and shutdown Windows fully (no hibernation
or fast restarting.)
Could not mount read-write, trying read-only

I do not need any saved sessions of windows or its data to be recovered as I have no important data there. I need to be able to dual boot endeavouros with windows 10. I am ready to reinstall windows or eos without altering the current home partiton (sdb7).


Normally the issue with Grub not showing boot entries for one or other system is caused by the fact that they are installed in different modes, BIOS/MBR/Legacy VS. UEFI.

To make sure, boot into your Windows system.
You could skip grub and instead bring up the one time boot menu. Depending on the make and model of your machine, you can do so by pressing a Fn key right after powering up.

Once in Windows:

  1. Press the Win + R keys to open Run, type msinfo32 into Run, and click/tap on OK to open System Information.

  2. In the right pane of System Summary in System Information, see if the BIOS Mode item has a value of Legacy or UEFI

1 Like

I could not boot into windows using any of the way I know, I tried pressing fn key, tried from boot menu, even toggling UEFI to legacy, all was for no use.

As far as I know, I had never used legacy mode to install any os in this laptop

I installed windows using Ventoy but installed endeavouros using etcher if it matters

It shouldn’t matter.

If you are going to reinstall as you mentioned, I would suggest to backup your important data.
No matter if you are keeping sdb7, things might go awry so it is better to be on the safe side.

will it be safe if i backup to the harddisk only? (which is inbuilt to this laptop). if that is the case i already have a backup there.

I already tried reinstalling as I mentioned in the question, if there is any specific things I should take in account while reinstalling windows again, please let me know. The windows installation only allows to select a partition for its installation, and once its installed, the linux partition mounted as /boot/efi was taken over by windows and grub won’t show while booting.

Reinstall windows into that partition.
Keep your EnOS as it is now.
We might be able to fix Grub later on if it ever gets overwritten.

Okay, I will reinstall windows now. Thank you for your time, I will let you know once installation is complete.

1 Like

Good luck!

Now I am in windows, the grub didnot show up during boot time. also i checked and found that BIOS mode is in UEFI

1 Like


  1. Go into your UEFI settings and check if there is a boot option for EnOS. If there is, give it the boot priority. Now, after reboot, you should be able to see grub boot menu.

  2. If there isn’t any boot option for EnOS in UEFI settings, you would need to use your EnOS’ live usb, chroot into your system and reinstall the grub bootloader.

You could post the output of the following commands from the live session:

sudo parted -l


Here is an article about how to chroot:

If you need step by step instructions, I’ll try to help.

1 Like

the boot option for EnOS is not available.

[liveuser@eos-2023.05.28 ~]$ sudo parted -l
Model: ATA TOSHIBA MQ04ABF1 (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size   File system  Name           Flags
 1      1049kB  322GB  322GB  ntfs         300gGBntfsHDD  msftdata

Model: ATA Netac SSD 512GB (scsi)
Disk /dev/sdb: 512GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size    File system     Name               Flags
 1      1049kB  107GB  107GB   ntfs            windows_partition  msftdata
 2      107GB   161GB  53.7GB  ntfs            common_partition   msftdata
 3      161GB   162GB  629MB   fat32           windowsbootloader  msftdata
 4      162GB   162GB  629MB   fat32                              boot, esp
 6      162GB   171GB  8590MB  linux-swap(v1)                     swap
 5      171GB   274GB  103GB   btrfs
 7      274GB   512GB  238GB   btrfs           linuxhome

Model: UFDBM T7 38 (scsi)
Disk /dev/sdc: 8120MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size   Type     File system  Flags
 2      1933MB  2049MB  116MB  primary  fat16        esp
[liveuser@eos-2023.05.28 ~]$ efibootmgr
BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0002,2001,2002,2003
Boot0000* USB HDD: UFDBM   T7 38	PciRoot(0x0)/Pci(0x14,0x0)/USB(3,0)/HD(1,MBR,0xb15bb315,0x399a80,0x37800)RC
Boot0002* Windows Boot Manager	HD(4,GPT,59ef96c6-2deb-5849-977d-e8bf2440016d,0x12d2c800,0x12c000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)57494e444f5753000100000088000000780000004200430044004f0042004a004500430054003d007b00390064006500610038003600320063002d0035006300640064002d0034006500370030002d0061006300630031002d006600330032006200330034003400640034003700390035007d00000000000100000010000000040000007fff0400
Boot2001* EFI USB Device	RC
Boot2003* EFI Network	RC

In the live session:

sudo mount -o subvol=@ /dev/sdb5 /mnt
sudo mount /dev/sdb4 /mnt/boot/efi
sudo arch-chroot /mnt

Now in chroot:

grub-mkconfig -o /boot/grub/grub.cfg

If you get any error messages at any stage, post them here.

If all is fine, type exit followed by enter to quit chroot.

Check with efibootmgr if a boot entry has been created and is first in boot order.
If so reboot and see if you get the grub boot menu.