Windows Boot Manager doesn't detect bootable USB

I am trying to install Endeavor OS on my system, but after creating a bootable USB, the USB doesn’t show up in the Boot Manager, I tried to look into the USB settings in BIOS, it shows the pendrive as Mass Storage device. I used the same method for some other device and it worked, but that was PopOS. I have been using vanilla Arch on some other system and am in no mood to go back to Ubuntu or PopOS for that matter.
This is my first post here, so correct me if I used any tag wrong.
Thank You.

How you created the bootable usb? Wich ISO you used?

And are you using BIOS or UEFI?

I created the bootable USB with rufus in Windows 11, I used the latest release - EndeavourOS_Atlantis_neo-21_5.iso. I am using UEFI. Apart from Rufus, I also used ImageWriter in Arch Linux and Balena Etcher in Windows 11.

Tried another USB Stick and other USB Port?

If nothing changed, follow these steps:

If you have Win10 I just went through this, and it still gives me a bit of trouble because I regrettably installed Endeavour with an encryption, so now Grub shows up and Windows won’t shut down or restart properly… it’s weird.
Anyway, what I had to do was go into the initial boot system (sorry if my terminology is wrong, I’m a n00b) and change the boot ordering so that the USB was 1st and my computer was 2nd. For my Dell that meant hitting F12 while the initial Dell screen was up, but for others, apparently, it’s F1 or ESC.
Also, for some (it didn’t show up for me, possibly because I’m using Ventoy?) you may be able to hold down SHIFT while you’re restarting Windows to access advanced startup features, which should include “Start from Device”.