Window manager not working?

I have encountered a strange problem. Not sure how it happened, but it was after updating the system a few days ago. No error messages per se, just the odd behavior from the system/window manager.

So, the problem is that I can not move any windows. Some times I can not write anything (for example in terminal), but other times I can. I keep loosing background images, and right-clicking does not seem to work on any windows.

I may have done things worse by trying to systemctl disable lightdm.something in an attempt to turn it ‘on/off’, but that seemed to remove something from the system, and that was not my intention.

I have switched between different wm’s, but they all have the same problems.

Any way to reinstall or ‘debug’ what is going on here? Any help is very welcome :slight_smile:

Goto terminal mode (console mode) at boot. Generally CTL-ALT-F2 will get you there if you don’t see it after booting.


Try to reinstall lightdm and enable lightdm.service

sudo pacman -S lightdm
sudo systemctl enable lightdm
1 Like

Thank you very much for your response! :slight_smile:
So I tried this; and got a sort of error message saying it was sym linked to something like lxdm … so it further said it was disabled, and I guess some of the problem is here? I tried to use systemctl to enable lxdm.service, and it did that without any messages back. Not sure if I do things worse again here?

Small update: I tried removing everything that had to do with xfce stuff, and that actually helped. I can now move, resize and activate windows again! So big step forward … :slight_smile:

So I am still stuck with a problem. There might be some others too, but this is the main one I think:

  • When I right-click on my desktop, it says ‘settings, change background and monitor settings’, but none of them do anything … (nothing happens when I click either). Anything I can do to fix that?

looks like a multidesktop installs system ?
If so may consider reinstalling and keep it cleaner by only use one at the time.