WiFi takes a long time to reconnect after closing laptop lid

Whenever I just close my laptop lid, it would take a long time for EOS to detect the WiFi networks around me, so it’s basically my computer showing there’s no networks for a few minutes and then it would then be able to find it.

I tried to search this problem up, one of them had hard lock on as their issue, but mine didn’t show any soft or hard lock enabled. Is there a way to resolve this? Alternatively, if this problem doesn’t get resolved, is there a better way to make the laptop sleep for a while instead of just closing the lid?

My output for inxi -Fxxxc is here:

  Host: ideapad Kernel: 5.19.8-arch1-1 arch: x86_64 bits: 64 compiler: gcc
    v: 12.2.0 Desktop: KDE Plasma v: 5.25.5 tk: Qt v: 5.15.6 wm: kwin_x11 vt: 1
    dm: 1: LightDM v: 1.32.0 note: stopped 2: SDDM Distro: EndeavourOS
    base: Arch Linux
  Type: Laptop System: LENOVO product: 82H8 v: IdeaPad 3 15ITL6
    serial: <superuser required> Chassis: type: 10 v: IdeaPad 3 15ITL6
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0J40688 WIN
    serial: <superuser required> UEFI: LENOVO v: GGCN20WW date: 01/13/2021
  ID-1: BAT0 charge: 1.9 Wh (5.9%) condition: 32.2/38.0 Wh (84.9%) volts: 7.7
    min: 7.7 model: BYD L20B2PF0 type: Li-poly serial: 563 status: charging
    cycles: 831
  Info: quad core model: 11th Gen Intel Core i7-1165G7 bits: 64 type: MT MCP
    smt: enabled arch: Tiger Lake level: v4 rev: 1 cache: L1: 320 KiB L2: 5 MiB
    L3: 12 MiB
  Speed (MHz): avg: 1600 high: 2800 min/max: 400/4700 cores: 1: 1201
    2: 2800 3: 2800 4: 1200 5: 1201 6: 1200 7: 1200 8: 1200 bogomips: 44864
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: Lenovo
    driver: i915 v: kernel arch: Gen-12.1 ports: active: eDP-1 empty: HDMI-A-1
    bus-ID: 0000:00:02.0 chip-ID: 8086:9a49 class-ID: 0300
  Device-2: NVIDIA TU117M [GeForce MX450] vendor: Lenovo driver: N/A
    arch: Turing bus-ID: 0000:01:00.0 chip-ID: 10de:1f97 class-ID: 0302
  Device-3: Chicony Integrated Camera type: USB driver: uvcvideo
    bus-ID: 3-5:3 chip-ID: 04f2:b725 class-ID: fe01 serial: 0001
  Display: x11 server: X.Org v: 21.1.4 compositor: kwin_x11 driver: X:
    loaded: intel unloaded: modesetting alternate: fbdev,vesa gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 mapped: eDP1 model: ChiMei InnoLux 0x151e res: 1920x1080
    hz: 60 dpi: 143 size: 340x190mm (13.39x7.48") diag: 394mm (15.5")
    modes: 1920x1080
  OpenGL: renderer: Mesa Intel Xe Graphics (TGL GT2) v: 4.6 Mesa 22.1.7
    direct render: Yes
  Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Lenovo
    driver: sof-audio-pci-intel-tgl bus-ID: 0000:00:1f.3 chip-ID: 8086:a0c8
    class-ID: 0401
  Sound Server-1: ALSA v: k5.19.8-arch1-1 running: yes
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.57 running: yes
  Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel
    bus-ID: 0000:00:14.3 chip-ID: 8086:a0f0 class-ID: 0280
  IF: wlan0 state: up mac: 4c:79:6e:e9:2d:11
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
    driver: btusb v: 0.8 bus-ID: 3-10:5 chip-ID: 8087:0aaa class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 3 state: down bt-service: disabled
    rfk-block: hardware: no software: no address: see --recommends
  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
    v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:9a0b rev:
    class-ID: 0104
  Local Storage: total: 476.94 GiB used: 13.61 GiB (2.9%)
  ID-1: /dev/nvme0n1 vendor: Lenovo model: UMIS RPJTJ512MEE1OWX
    size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 type: SSD
    serial: SS1B60639Z1CD13T11RP rev: 2.1C0628 temp: 49.9 C scheme: GPT
  ID-1: / size: 143.13 GiB used: 13.57 GiB (9.5%) fs: ext4
    dev: /dev/nvme0n1p5
  ID-2: /boot/efi size: 256 MiB used: 33.4 MiB (13.0%) fs: vfat
    dev: /dev/nvme0n1p1
  Alert: No swap data was found.

Have you tried the LTS kernel?

Do you have Hybrid-sleep setup? Hibernate?

What does the output of systemd-analyze and systemd-analyze blame come up with?

1 Like

If you mean doing sudo pacman -S linux-lts linux-lts-headers, I’m currently trying that out.

I have not heard of hybrid-sleep or hibernate before, how do I set those up?

Output of systemd-analyze:

Startup finished in 2.979s (firmware) + 721ms (loader) + 1.432s (kernel) + 3.462s (userspace) = 8.595s 
graphical.target reached after 3.438s in userspace.

systemd-analyze blame:

2min 51.252s systemd-suspend.service
      2.957s systemd-modules-load.service
       965ms dev-nvme0n1p5.device
       482ms systemd-udev-trigger.service
       472ms boot-efi.mount
       358ms systemd-tmpfiles-setup.service
       329ms systemd-fsck@dev-disk-by\x2duuid-C2C6\x2d34F2.service
       225ms firewalld.service
       157ms systemd-journald.service
       148ms lvm2-monitor.service
       124ms upower.service
       110ms modprobe@fuse.service
        95ms systemd-timesyncd.service
        93ms systemd-rfkill.service
        90ms systemd-udevd.service
        88ms user@1000.service
        64ms sys-kernel-debug.mount
        63ms dev-mqueue.mount
        63ms systemd-tmpfiles-setup-dev.service
        62ms sys-kernel-tracing.mount
        62ms dev-hugepages.mount
        61ms modprobe@drm.service
        61ms systemd-remount-fs.service
        57ms modprobe@configfs.service
        57ms tmp.mount
        56ms kmod-static-nodes.service
        55ms systemd-journal-flush.service
        45ms systemd-random-seed.service
        40ms systemd-update-utmp.service
        31ms udisks2.service
        30ms power-profiles-daemon.service
        23ms cups.service
        22ms systemd-logind.service
        20ms avahi-daemon.service
        18ms systemd-tmpfiles-clean.service
        17ms dbus.service
        17ms sys-fs-fuse-connections.mount
        15ms NetworkManager.service
        14ms sys-kernel-config.mount
         9ms polkit.service
         6ms user-runtime-dir@1000.service
         6ms wpa_supplicant.service
         5ms systemd-backlight@backlight:ideapad.service
         3ms systemd-sysctl.service
         2ms alsa-restore.service
         2ms systemd-backlight@backlight:intel_backlight.service
         2ms systemd-user-sessions.service
         2ms rtkit-daemon.service

Well hello problem. 2min 51 seconds for systemd-suspend.service?!?! Let’s see if we can fix that.

I see a couple things from the googling suggesting that could be a kernel thing. Try the LTS first before anything else.

ok, i have installed linux LTS, and it seems to be good now?

Closing the lid seems to be working fine, and right now, my screen has not been turning off when I leave it alone (not sure how to check what the default behavior should be when leaving it idle)

systemd-analyze blame output:

677ms systemd-rfkill.service
475ms systemd-modules-load.service
318ms dev-nvme0n1p5.device
278ms lvm2-monitor.service
210ms upower.service
176ms firewalld.service
170ms user@1000.service
 78ms ldconfig.service
 58ms systemd-udev-trigger.service
 49ms systemd-logind.service
 46ms systemd-journal-flush.service
 38ms systemd-udevd.service
 31ms systemd-journald.service
 30ms power-profiles-daemon.service
 27ms udisks2.service
 22ms avahi-daemon.service
 20ms systemd-timesyncd.service
 19ms systemd-tmpfiles-setup.service
 19ms cups.service
 18ms systemd-sysusers.service
 17ms dbus.service
 16ms systemd-tmpfiles-setup-dev.service
 16ms NetworkManager.service
 15ms systemd-fsck@dev-disk-by\x2duuid-C2C6\x2d34F2.service
  9ms modprobe@fuse.service
  8ms systemd-backlight@backlight:ideapad.service
  7ms boot-efi.mount
  7ms polkit.service
  7ms systemd-journal-catalog-update.service
  7ms user-runtime-dir@1000.service
  7ms dev-hugepages.mount
  7ms dev-mqueue.mount
  6ms sys-kernel-debug.mount
  6ms sys-kernel-tracing.mount
  6ms systemd-backlight@backlight:intel_backlight.service
  6ms wpa_supplicant.service
  5ms tmp.mount
  5ms systemd-random-seed.service
  5ms kmod-static-nodes.service
  5ms alsa-restore.service
  4ms modprobe@configfs.service
  4ms rtkit-daemon.service
  3ms systemd-user-sessions.service
  3ms systemd-remount-fs.service
  3ms systemd-sysctl.service
  3ms systemd-update-utmp.service
  2ms systemd-update-done.service
  1ms modprobe@drm.service
  1ms sys-kernel-config.mount
914us sys-fs-fuse-connections.mount
1 Like

If you don’t need to run the latest kernel, I generally don’t recommend it as they are always building it, sometimes there are regressions.

If you’re still having the issues, post on back.



Yeah I just didn’t know I wasn’t running on LTS, thanks so much!

No worries. Always glad to help!


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.