Wifi suddenly stop to work in kde plasma desktop

Hi there,
I switched from i3 to KDE plasma. I didn’t had any issues with wifi in i3 but in kde When I am surfing the internet After in 20 or 30 mins the wifi doesn’t work. I have to enable and disable it manually to work.
How can I fix this. I also use bluetooth speaker. Its same for the speaker also. After running for a while it suddenly stops receiving sounds although it is connected.

I don’t know if my issue is related to yours, but, if I remember correctly, since Kernel 6.1, I had issues with WiFi, after suspending the computer and waking it up, the WiFi was completely gone, as if no WiFi card was connected to the system and since kernel 6.1.2, I have no WiFi at all, it seems that the module for the driver of my card, or doesn’t load at all or it crashes as soon as the system tries to load it, yet, I wasn’t able to see anything related to the driver crashing on boot, so I don’t really know what’s going on.
At the moment I switched to kernel 6.0 and my WiFi works just as it should (at least since before kernel 6.1.2).
Is there any log files we can offer to try to solve this?
Since the problem begun, two kernel updates had been released and it doesn’t seem that anyone is aware of the problem.

Hi !
Thank you for noticing my problems. I thought it was the problem of kde. And i switched back to i3wm but its same. Wifi suddenly stops working while I am browsing. Which kernel are you using? How can I roll back to 6.0 version?

Hello! :smiley:
In order to downgrade a package you use “downgrade”, in this case simply introduce:

sudo downgrade linux

where linux is the “current” kernel (in case you are using another kernel specify the name of that kernel, for example “linux-lts”).
This will give you a list of available versions of that kernel, now simply introduce the number on the list for the respective kernel that you want to downgrade to and then press enter, follow the easy instructions (you can choose to blacklist the kernel as one of the options available in the process, in case you don’t want it to get updated while the issue gets fixed for a newer version), and once the older kernel is installed simply reboot the system, your system should be working “normally” once the computer reboots.

Hope that helps! :+1:


Thank you. :smiley:
I will use lts kernell for some time. I am getting best experience. Haven’t have any issues yet. I will probably stick with it for some time.
Thank you again for helping me. I learned new way to downgrade package. :grinning:

1 Like