WiFi speed drastically drops when resuming from sleep


Each time I get the computer out of sleep, the WiFi connection speed drops to 1Mbps MAX, which is very low speed, far lower from what it normally is (actually, not each time, most of the time, don’t really know, is it when it goes to sleep on its own, or when I put it to sleep myself, dunno… will try to see if there is a clear pattern… but if it never sleeps, then the speed never goes down)

I tried the suggestions referenced in the arch wiki without success.

When that happen I don’t know what to do except reboot the computer.
Disconnect/reconnect WiFi doesn’t hep.
Restarting NetworkManager doesn’t help.

I think I am not really able to investigate any further myself unfortunately, hence any help would be greatly appreciated !

Hardware information

Last journal (I guess resume from sleep is around that time stamp janv. 20 12:45:49)

Cheers !

1 Like

No idea ?

I don’t know I could address this problem :frowning:

This sounds like a driver issue. Try some different kernels to see if that helps (5.10, 5.15, 5.16, etc.). Also check whether it’s connecting to a different AP, or whether disabling MAC randomisation (if it’s enabled) helps.

I can’t see any reference to a “sleep” or “resume” step in that journal output.


Thanks a lot for the suggestions.
MAC randomization is indeed enabled. I will try and disable it, as well as different kernel version.
And I will take a journal when/if that happens (thought it would appeared on the one i posted :confused:).

Cheers !

1 Like


So I try and “tweak” many parameters without success, after a while WiFi connection speed drop to 0,5-1Mbps… and never goes back up… (but it’s not off, I can still ping addresses)
And, SOMETIMES, if I restart wpa_supplicantOR NetworkManager the full speed is restored… for about 1 minute :sob:

I’m still unable to make it work for good (and I’m so sorry!)


(I try and replace wpa_supplicant with iwd but the exact same behavior happens)

If that helps:
dmesg -rl warn,err,crit

Listing it as working for Manjaro and Garuda, but your issue comes with suspend/hibernate.
I would try find out if there are options for the device for p.e. disable powersaving ?
Could be also
janv. 20 12:07:40 lmm-hpebk840g7nbpc systemd[1]: Starting TLP system startup/shutdown...
where you could configure it so it will not go into powersave mode.

what also is mentioned in archwiki:

In case this does not work for you, you may try disabling power saving for your wireless adapter.

And you can try disable TLP to see if it is causing the wifi to go into powersaving mode.

1 Like

Hello again

So, now, I am always connected to 1Mbs max.
The very first seconds after I boot up I get full speed, and then I’m stuck for ever at that speed.

I really don’t know what to do (or even how to investigate that properly).

I did try different kernels.
I did try all the options from the wiki (and more) for the wireless adapter.
I switched back and forward from wpa_supplicant to iwd
It never changed anything to the first problem.
Now it’s even worse as before cause it is all the time ! (before it was just after being put to sleep and resume) even though I’m back to my original “config” (and the tweaks never changed anything in the first place)

If anybody as any clue (I am so sorry that I don’t even know what logs would be relevant here… if you could help me on that too :-/ ) it would be so wonderful !

Thanks so much !!


I don’t know if anyone could help me but I took a new log and I wonder if the problem could be “readable” on it:

Thanks so much for your time !

Cheers !