Wifi not working because "No network devices available"

I’ll dump a bunch of information here before I describe the problem:

Hardware information:
https://clbin.com/OFD2b

Boot log:
https://clbin.com/v7b2f

ip link (I am using usb tethering with my iPhone):
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp0s20u2c4i2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP mode DEFAULT group default qlen 1000
link/ether 8a:19:08:02:f6:9b brd ff:ff:ff:ff:ff:ff

rfkill list (wifi isn’t even showing up):
0: hci0: Bluetooth
Soft blocked: yes
Hard blocked: no

NetworkManager is active and running

ping 8.8.8.8:
ping: connect: Network is unreachable

Onto the actual post:

Wifi isn’t working in the live environment or after installation. After I click on the wifi button on the bottom bar, I can not select any networks. Wifi has worked on every other distro I tried, including Arch (although I used iwd for Arch), so I’m not sure why it refuses to work on EOS.

It should be using brcmfmac kernel module. You may need to blacklist broadcom-wl? Or some other module.

1 Like

Check the following.

lsmod | grep wl

1 Like

Maybe try

sudo rmmod wl
sudo modprobe brcmfmac
2 Likes

and i see this in archwiki:

No 5GHz for BCM4360 (14e4:43a0) / BCM43602 (14e4:43ba) devices

Issue appears to be linked to a channel issue. Changing the wireless channel to a lower channel number (like 40 or, if your router show MHz instead of channel numbers, like 5200 MHz or 5280 MHz) seems to allow connection to 5GHz bands. If your router has the same SSID for the 2.4GHZ and 5GHZ, this can fix problems with your wireless connection being unstable or very slow.

but indeed it will be broadcom-wl if it is used you should try what @ricklinux say and if it works remove broadcom-wl.

1 Like

This worked! Many thanks.

Does it stay when you reboot? Or you may have to remove broadcom-wl.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.