Wifi network disconnects and reconnects every few minutes

I have a Lenovo Ideapad Y560 and have it set up with triple booting of Linux Mint 19.3, EndeavourOS with Deepin, and EndeavourOS with Cinnamon. I have both the built in Intel PCI WiFi card and an external USB WiFi adapter. The internal WiFi is kind of iffy, so I’ve blacklisted it (iwlwifi) from the kernel modules in /etc/modprobe.d on all 3 installs to get it out of the way and have rtl88x2bu driver installed on all 3 for the external usb adapter. What I’ve found is that EndevourOS with Deepin, seems slow connecting to my wifi (even being in the same room as the router). Once it does connect, every few minutes, it drops the connection, and then takes 30seconds to 1 minute to reconnect again. This continues while using this install. I’ve also tried with the built in PCI Wifi card and it does the same (and probably more often). Also tried with two other adapters (and installing the right drivers for them, rtl88xxau) and they behave the same way.

My Linux Mint 19.3 does not do this at all with the same set up. So I installed EndeavourOS with Cinnamon only (clean fresh install) and it behaves like Linux Mint with no problem (and it is using the exact same drivers from AUR like the Deepin version is using. As a side note, I also tried the beta (alpha really) of UbuntuDDE Linux and it behaved similar to the Deepin on EndevourOS with wifi disconnecting and really slow reconnecting.

I’m assuming NetworkManager between the different DE’s is the same. This seems like a Deepin issue to me, but really not sure where to look or what to check. I’d be happy to provide any logs or anything else you might want to help debug this.

Thanks! This is my first time working with Archlinux of any form, and I’m really enjoying it (at least the network of stability of the Cinnamon install, which is what I’m working on now to write this). Thanks for the work on EndeavourOS!

No ideas on this? Nobody else has experienced similar?

I have seen wi-fi do this, but not on a PC system. No help here, I’m afraid. I do, however, suspect that Deepin may well be the problem. A number of odd issues seem to remain in that DE, and the new release 20 is coming soon - intended to be more ‘professionally accessible’. That may resolve your issue. Sometimes we just run out of ideas!

Deepin for me has always had trouble with new network connections. Seems more stable to set it up in xfce and then Deepin can use it

In the wake of @Amsterdam4572 idea, do a Gnome install next to Deepin, since Deepin has a lot of Gnome DNA in it, then set the network up in Gnome and see if you still have trouble on both DEs.

To install Gnome read this:

Also maybe configure networkmanager not to use random mac addresses, as described in the Arch wiki entry for Deepin ?

https://wiki.archlinux.org/index.php/Deepin_Desktop_Environment

Maybe this is works. Add the following lines to this file.

/etc/NetworkManager/NetworkManager.conf

[device]
wifi.scan-rand-mac-address=no

Save this in the file and restart NetworkManager.

systemctl restart networkmanager

Ok, so how would I do this? I have side loaded XFCE4. Do I need to log out of Deepin and log into xfce4 then do the configuration, then log back in to Deepin? Or under Deepin do I run xfce4 apps? I didn’t see network specific ones offhand.

Yes, I had found that and already tried that. Also made sure I was on the latest version of NetworkManager as I had seen issues with some older versions and having to do some dhcp=dhcpd hack also.

Just login to xfce and set it up there. Then logout and login to Deepin

Ok, so I played around and didn’t make any progress doing a side load of xfce4 and gnome. Finally decided that since I really hadn’t done much with EndeavourOS, I’d just do a fresh install with xfce4 as the DE, and then set it all up under xfce4. After I got my WiFi and all configured, I then did a side load of Deepin, and am happy to say my WiFi is stable now for the past hour or so. I do have two WiFi applets in my dock now, so I know the one is from xfce and the other is from Deepin. Should I get rid of one of them (I assume the Deepin one)? If so, how do I do that?

I have 2 applets in the dock. Just left them both there

1 Like