WIFI Network Connection issue after kernel 6.2.5-arch1-1 upgrade

Hello folks,
I just did an update on my system (I didn’t see anything about any intervention needed online) and it upgraded me to kernel 6.2.5-arch1-1. Upon rebooting I seemed to have lost my ability to connect to my wifi. I did a little digging online and I was able to find some information on a potential fix. Looking at nmcli everything seemed fine. When I ran journalctl -u NetworkManager -b I found this in the log

Mar 12 14:31:06 danny-macbookpro92 NetworkManager[571]: <warn>  [1678649466.2180] device (wlan0): Activation: (wifi) association took too long
Mar 12 14:31:06 danny-macbookpro92 NetworkManager[571]: <info>  [1678649466.2182] device (wlan0): state change: config -> need-auth (reason 'none', sys-iface-state: 'managed')
Mar 12 14:31:06 danny-macbookpro92 NetworkManager[571]: <warn>  [1678649466.2196] device (wlan0): Activation: (wifi) asking for new secrets
Mar 12 14:31:06 danny-macbookpro92 NetworkManager[571]: <warn>  [1678649466.2203] device (wlan0): no secrets: No agents were available for this request.
Mar 12 14:31:06 danny-macbookpro92 NetworkManager[571]: <info>  [1678649466.2204] device (wlan0): state change: need-auth -> failed (reason 'no-secrets', sys-iface-state: 'managed')
Mar 12 14:31:06 danny-macbookpro92 NetworkManager[571]: <warn>  [1678649466.2221] platform-linux: do-change-link[3]: failure 23 (Too many open files in system) (assume success changing address)
Mar 12 14:31:06 danny-macbookpro92 NetworkManager[571]: <info>  [1678649466.2224] device (wlan0): set-hw-addr: set MAC address to 12:D0:60:7E:C8:DA (scanning)
Mar 12 14:31:06 danny-macbookpro92 NetworkManager[571]: <warn>  [1678649466.2230] device (wlan0): Activation: failed for connection 'Tanuki'

From what I can tell this may be my solution, since it looks like it is timing out when trying to get a connection.

I have tried deleting the profile and creating a new one, and that didn’t help me out. So the only other step it lists was to create some wifi_rand_mac.conf file (since that is not on my system) so that I can disable MAC address randomization. So I decided to reach out to the good folks here to see if anyone else has had this sort of issue before. I don’t have a problem making some file to try this, but I also don’t want to break things more mucking around with things I don’t fully understand. I am not a Linux, or networking expert. And if this is the way to go, does anyone know why all of a sudden I would need to disable this? I have never had an issue with it connecting before, just trying to learn more before I break things more. Any help, or thoughts, would be greatly appreciated. Cheers

Did you try the LTS kernel yet?

sudo pacman -S linux-lts linux-lts-headers

The Zen kernel might also be a viable alternative:

sudo pacman -S linux-zen linux-zen-headers


I would try the MAC address randomization

Edit: It can’t hurt as it either works or doesn’t. You can always remove it later.

Well I created the file and couldn’t get it to do anything different, so I rebooted. And that just completely disabled my Network Manager. So I tried to start and enable Network Manager through systemctl, and it did not like that. It told me to get more details by running systemctl status NetworkManager.service
That gave me the following

× NetworkManager.service - Network Manager
     Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; preset: disabled)
     Active: failed (Result: exit-code) since Sun 2023-03-12 15:47:01 CDT; 21s ago
       Docs: man:NetworkManager(8)
    Process: 2207 ExecStart=/usr/bin/NetworkManager --no-daemon (code=exited, status=1/FAILURE)
   Main PID: 2207 (code=exited, status=1/FAILURE)
        CPU: 22ms

Mar 12 15:47:01 danny-macbookpro92 systemd[1]: NetworkManager.service: Scheduled restart job, restart counter is at 5.
Mar 12 15:47:01 danny-macbookpro92 systemd[1]: Stopped Network Manager.
Mar 12 15:47:01 danny-macbookpro92 systemd[1]: NetworkManager.service: Start request repeated too quickly.
Mar 12 15:47:01 danny-macbookpro92 systemd[1]: NetworkManager.service: Failed with result 'exit-code'.
Mar 12 15:47:01 danny-macbookpro92 systemd[1]: Failed to start Network Manager.

So I removed that little file and rebooted, everything came up fine in regards to Network Manager starting. But still no ability to connect to WIFI. I even tried my fallback option on GRUB. So I will have to do some more poking around. I could also try the other kernels as @ivanhoe mentioned. I am running an older macbook so I think the zen kernel may not work great on this machine. I could try installing the LTS kernel. But I will see if I can’t figure something else out on this thing in the meantime. I guess I could also downgrade my linux kernel as well. But that seems like it could also cause some breakage, I have never downgraded anything before.

Well it’s entirely up to you what you do. I myself am not one to use an lts kernel every time there’s a problem. But then again, I am not using old or older hardware. In my circumstances and if i had a similar problem that was in fact working before i upgraded and if it was a kernel upgrade that caused it I would downgrade back to the previous kernel. If in fact it is not a kernel upgrade and is some other upgraded packages then i would attempt to figure out what the upgrades were by looking at the pacman log.

1 Like

Fair enough, so I just downgraded my kernel. This may be a dumb question, but do I also need to downgrade the linux-headers package?

Yes you have to do that also. I usually do it in the same command.

Ayup. Especially if you’re using old Apple HW, you could take a look here.

What is the make and model of your MBP?

I figured I would need to do both, as soon as I ran the command for downgrade I was thinking I should have done them together. So after the downgrade all is well. So something that I did think was strange is that I was previously on kernel 6.2.2.-arch2-1, so when I upgraded 6.2.5-arch1-1 it was kind of weird that it would skip from 6.2.2 to 6.2.5

I have a mid 2012 Macbook Pro 9.2

Arch kernels often come out more than once a week. You should look to find a stable solution to your problem (LTS).

Also, a future update of the Arch Linux kernel might solve your issue again. Therefore, downgrading the kernel is not really preferable, imo…

So you take the approach of running the standard kernel, and if an update causes an issue you just swap to LTS until a new update to the standard fixes it? Then hop back to it? Is that different than running the standard kernel and if something breaks then downgrading until a new update comes out and then just upgrading to that one? I have never ran two kernels on my machine, I am just trying to understand the troubleshooting approaches.

And to be honest the only time prior to this update that I had a kernel issue was back in November maybe when an update took out my WIFI, different issue. My drivers didn’t work anymore. It was late at night so I did a little troubleshooting, and ended up going to bed and when I woke up there was another kernel update so I did that and it fixed my problem. I figured on that one I was going to have to downgrade in the morning if I couldn’t figure it out.


Nope. My approach would be to stick with the LTS kernel, instead of downgrading Linux. LTS will eventually be upgraded, too, just not as quickly and more failsafe.

Ok I am tracking now, you just run on LTS since it is more failsafe than the standard kernel. Thanks for the clarity

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.