Wifi Does not connect since last update

So, since the last Full Sys update on my laptop, a couple of days ago, the WiFi does not connect anymore. I can only try one WiFi address currently but network manager displays all WiFi addresses in the area, when I put in the password it connects for less than a second and disconnects. Password is correct and WiFi works on other devices and laptop is currently connected to router via ethernet (not a long term solution though).

Output of inxi -Na

Device-1: Intel Tiger Lake PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:43f0 class-ID: 0280
Device-2: Intel Ethernet I219-V vendor: CLEVO/KAPOK driver: e1000e
    v: kernel port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15fa class-ID: 0200

Output of iw dev

phy#0
  Unnamed/non-netdev interface
                wdev 0x3
                addr 8c:b8:7e:ee:0e:fe
                type P2P-device
                txpower 0.00 dBm
        Interface wlan0
                ifindex 4
                wdev 0x2
                addr 8c:b8:7e:ee:0e:fd
                type managed
                txpower 0.00 dBm
                multicast TXQ:
                        qsz-byt qsz-pkt flows   drops   marks   overlmt hashcol tx-bytes        tx-packets
                        0       0       0       0       0       0       0       0               0

lspci -k Gives:

00:14.3 Network controller: Intel Corporation Tiger Lake PCH CNVi WiFi (rev 11)
        Subsystem: Intel Corporation Wi-Fi 6 AX201 160MHz
        Kernel driver in use: iwlwifi
        Kernel modules: iwlwifi

journalctl -f gives out some errors while trying to connect to wifi, is there a way to filter out personal data from a journalctl log?

I’ve tried changing to LTS kernel, no dice.
Other threads didn’t have the solution applicable to me.

What can I do?

sudo rfkill list   

Returns?

rfkill list:

>0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
1: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no

Forgot to add systemctl status iwd.service

● iwd.service - Wireless service
     Loaded: loaded (/usr/lib/systemd/system/iwd.service; disabled; preset: disabled)
     Active: active (running) since Tue 2022-12-27 22:41:18 EST; 11h ago
       Docs: man:iwd(8)
             man:iwd.config(5)
             man:iwd.network(5)
             man:iwd.ap(5)
   Main PID: 506 (iwd)
      Tasks: 1 (limit: 18912)
     Memory: 2.2M
        CPU: 2.925s
     CGroup: /system.slice/iwd.service
             └─506 /usr/lib/iwd/iwd
Dec 28 10:15:30 XXX iwd[506]: wiphy_estimate_data_rate() failed
Dec 28 10:15:43 XXX iwd[506]: wiphy_estimate_data_rate() failed
Dec 28 10:15:58 XXX iwd[506]: wiphy_estimate_data_rate() failed
Dec 28 10:16:00 XXX iwd[506]: wiphy_estimate_data_rate() failed
Dec 28 10:16:30 XXX iwd[506]: wiphy_estimate_data_rate() failed
Dec 28 10:16:59 XXX iwd[506]: wiphy_estimate_data_rate() failed
Dec 28 10:17:45 XXX iwd[506]: wiphy_estimate_data_rate() failed
Dec 28 10:18:00 XXX iwd[506]: wiphy_estimate_data_rate() failed
Dec 28 10:18:30 XXX iwd[506]: wiphy_estimate_data_rate() failed
Dec 28 10:19:00 XXX iwd[506]: wiphy_estimate_data_rate() failed

journalctl -f while trying to connect to WiFi:

Dec 28 10:33:52 XXX NetworkManager[482]: <info>  [1672241632.5153] device (wlan0): Activation: starting connection 'BELLXXX' (cfb3529c-c583-45c0-ac7a-912906db01bd)
Dec 28 10:33:52 XXX audit[482]: USYS_CONFIG pid=482 uid=0 auid=4294967295 ses=4294967295 msg='op=connection-activate uuid=cfb3529c-c583-45c0-ac7a-912906db01bd name="BELLXXX" pid=1011 uid=1000 result=success exe="/usr/bin/NetworkManager" hostname=? addr=? terminal=? res=success'
Dec 28 10:33:52 XXX NetworkManager[482]: <info>  [1672241632.5154] audit: op="connection-activate" uuid="cfb3529c-c583-45c0-ac7a-912906db01bd" name="BELLXXX" pid=1011 uid=1000 result="success"
Dec 28 10:33:52 XXX NetworkManager[482]: <info>  [1672241632.5154] device (wlan0): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'managed')
Dec 28 10:33:52 XXX NetworkManager[482]: <info>  [1672241632.5156] device (wlan0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
Dec 28 10:33:52 XXX NetworkManager[482]: <info>  [1672241632.5166] device (wlan0): state change: config -> need-auth (reason 'no-secrets', sys-iface-state: 'managed')
Dec 28 10:33:52 XXX NetworkManager[482]: <warn>  [1672241632.5168] device (wlan0): No agents were available for this request.
Dec 28 10:33:52 XXX NetworkManager[482]: <error> [1672241632.5171] device (wlan0): Activation: (wifi) Network.Connect failed: GDBus.Error:net.connman.iwd.Aborted: Operation aborted
Dec 28 10:33:52 XXX NetworkManager[482]: <info>  [1672241632.5172] device (wlan0): state change: need-auth -> failed (reason 'no-secrets', sys-iface-state: 'managed')
Dec 28 10:33:52 XXX NetworkManager[482]: <warn>  [1672241632.5173] device (wlan0): Activation: failed for connection 'BELLXXX'
Dec 28 10:33:52 XXX NetworkManager[482]: <info>  [1672241632.5174] device (wlan0): state change: failed -> disconnected (reason 'none', sys-iface-state: 'managed')
Dec 28 10:33:52 XXX kernel: audit: type=1111 audit(1672241632.513:155): pid=482 uid=0 auid=4294967295 ses=4294967295 msg='op=connection-activate uuid=cfb3529c-c583-45c0-ac7a-912906db01bd name="BELLXXX" pid=1011 uid=1000 result=success exe="/usr/bin/NetworkManager" hostname=? addr=? terminal=? res=success'

Is wpa_supplicant.service also running? What is the reason that you use iwd.service instead if I might ask?

How do I check for wpa_supplicant? I think iwd was already running, and I must’ve used it while looking at another thread…

systemctl status wpa_supplicant

I switch to iwd on all my Arch installs right at the outset. For me, it has been a viable replacement to wpa_supplicant. It is also what is used on Arch ISO and quite lean on resources.

 wpa_supplicant.service - WPA supplicant
     Loaded: loaded (/usr/lib/systemd/system/wpa_supplicant.service; disabled; preset: disabled)
     Active: inactive (dead)

did systemctl enable wpa_supplicant

Created symlink /etc/systemd/system/dbus-fi.w1.wpa_supplicant1.service → /usr/lib/systemd/system/wpa_supplicant.service.
Created symlink /etc/systemd/system/multi-user.target.wants/wpa_supplicant.service → /usr/lib/systemd/system/wpa_supplicant.service.

systemctl status wpa_supplicant again

wpa_supplicant.service - WPA supplicant
     Loaded: loaded (/usr/lib/systemd/system/wpa_supplicant.service; enabled; preset: disabled)
     Active: inactive (dead)

WiFi still does not connect

You don’t need to enable wpa_supplicant if you are already using iwd.
It’s either one or the other.

Have you already created a iwd.conf file?

What is the output of:

ls /etc/NetworkManager/conf.d

?

It’s not active.You can disable iwd first then try enabling wpa_supplicant.

I did systemctl disable iwd.service

a status check for iwd returned:

iwd.service - Wireless service
     Loaded: loaded (/usr/lib/systemd/system/iwd.service; disabled; preset: disabled)
     Active: active (running) since Tue 2022-12-27 22:41:18 EST; 12h ago
       Docs: man:iwd(8)
             man:iwd.config(5)
             man:iwd.network(5)
             man:iwd.ap(5)
   Main PID: 506 (iwd)
      Tasks: 1 (limit: 18912)
     Memory: 2.2M
        CPU: 3.232s
     CGroup: /system.slice/iwd.service
             └─506 /usr/lib/iwd/iwd

Dec 28 11:19:09 XXX iwd[506]: wiphy_estimate_data_rate() failed

wpa_supplicant has same status as previous message

Run those commands as root… sudo systemctl…

I have, I just didn’t add it in thread for sake of brevity

1 Like

If I was you I would disable iwd and enable wpa, reboot and try connecting to your wifi. Not that there is anything wrong with iwd as pebcak said.

Rebooted, same issue.

Status check for wpa_supplicant:

wpa_supplicant.service - WPA supplicant
     Loaded: loaded (/usr/lib/systemd/system/wpa_supplicant.service; enabled; preset: disabled)
     Active: active (running) since Wed 2022-12-28 11:37:07 EST; 3min 50s ago
   Main PID: 458 (wpa_supplicant)
      Tasks: 1 (limit: 18912)
     Memory: 3.2M
        CPU: 2ms
     CGroup: /system.slice/wpa_supplicant.service
             └─458 /usr/bin/wpa_supplicant -u -s -O /run/wpa_supplicant

Dec 28 11:37:07 XXX systemd[1]: Starting WPA supplicant...
Dec 28 11:37:07 XXX systemd[1]: Started WPA supplicant.
Dec 28 11:37:07 XXX wpa_supplicant[458]: Successfully initialized wpa_supplicant

iwd is apparently still active despite disabling it?

iwd.service - Wireless service
     Loaded: loaded (/usr/lib/systemd/system/iwd.service; disabled; preset: disabled)
     Active: active (running) since Wed 2022-12-28 11:37:07 EST; 3min 45s ago
       Docs: man:iwd(8)
             man:iwd.config(5)
             man:iwd.network(5)
             man:iwd.ap(5)
   Main PID: 524 (iwd)
      Tasks: 1 (limit: 18912)
     Memory: 2.1M
        CPU: 27ms
     CGroup: /system.slice/iwd.service
             └─524 /usr/lib/iwd/iwd

Dec 28 11:37:07 XXX iwd[524]:                         Max HE RX <= 160MHz MCS: 0-11 for NSS: 2
Dec 28 11:37:07 XXX iwd[524]:                         Max HE TX <= 160MHz MCS: 0-11 for NSS: 2
Dec 28 11:37:07 XXX iwd[524]:         Ciphers: BIP-GMAC-256 BIP-GMAC-128 GCMP-256 GCMP-128
Dec 28 11:37:07 XXX iwd[524]:                  BIP-CMAC-128 CCMP-128 TKIP
Dec 28 11:37:07 XXX iwd[524]:         Supported iftypes: ad-hoc station ap p2p-client p2p-go p2p-device
Dec 28 11:37:26 XXX iwd[524]: wiphy_estimate_data_rate() failed
Dec 28 11:39:53 XXX iwd[524]: Could not register frame watch type 00d0: -114
Dec 28 11:40:36 XXX iwd[524]: wiphy_estimate_data_rate() failed
Dec 28 11:40:36 XXX iwd[524]: wiphy_estimate_data_rate() failed
Dec 28 11:40:38 XXX iwd[524]: wiphy_estimate_data_rate() failed

???

After disabling iwd you can remove the package. sudo pacman -R iwd

@anonemouse
Have you tried removing iwd and then try enable wpa_supplicant?

I removed iwd, and now I can’t see any WiFi networks at all. Ethernet still works though.

Status of wpa-supplicant:

wpa_supplicant.service - WPA supplicant
     Loaded: loaded (/usr/lib/systemd/system/wpa_supplicant.service; enabled; preset: disabled)
     Active: active (running) since Wed 2022-12-28 12:19:51 EST; 33s ago
   Main PID: 498 (wpa_supplicant)
      Tasks: 1 (limit: 18909)
     Memory: 3.2M
        CPU: 3ms
     CGroup: /system.slice/wpa_supplicant.service
             └─498 /usr/bin/wpa_supplicant -u -s -O /run/wpa_supplicant

Dec 28 12:19:51 XXX systemd[1]: Starting WPA supplicant...
Dec 28 12:19:51 XXX wpa_supplicant[498]: Successfully initialized wpa_supplicant
Dec 28 12:19:51 XXX systemd[1]: Started WPA supplicant. 

I’ll try again while rebooting in the lts kernel

Rebooted in LTS kernel, same.