WiFi disconnecting repeatedly with password prompt

Hi guys. I’ve been struggling with a WiFi problem for a couple weeks. My home network used to work fine for me, I’ve been on EOS for maybe 5 months on this machine and another year or so on an old laptop I had. Never had an issue with it. Just recently, it might have been after a system update but for some reason it seems to have come on slowly and gotten worse over time, it has been kicking me out randomly. It’ll tell me “incorrect password for MilPepOrbi” and prompt me to re-enter the password, as if the password had changed while I was still connected to the network! Entering the correct password naturally does not let me back in. It takes a while, from a few minutes to several hours for it to allow me to connect again.

No other devices in the house have had any troubles with this network. They’re all running Windows or Android. I know it’s not with just any WiFi because I can connect to my phone’s mobile hotspot just fine. I don’t know the technical differences between a mobile hotspot and a standard WiFi network, but I certainly also can’t lug my desktop over to a Starbucks to see whether it can connect to their free WiFi either, so this is my best evidence. All I can say is that the connection settings in NetworkManager look the same on both networks and they’re both using the 2.4GHz band.

Here is the output of inxi -FAZ --no-host:

And here is journalctl -xb since the last time I connected to my home network (it worked for a while, then prompted me for the password twice):

Your BIOS is awfully outdated: https://www.msi.com/Motherboard/B550M-PRO-VDH-WIFI/support

You could try to use iwd https://wiki.archlinux.org/title/iwd instead of wpa_supplicant

Also use nm-openvpn - for time of troubleshooting you could disable it, to see it it helps.

You can Google more info with this:
Reason: 3=DEAUTH_LEAVING as this is error in your logs.

I would say so. :wink:

This is a dual band chip using 2.4 Ghz. You could try using a different channel. Also have you tried it on 5 ghz.

Edit: Possibly some kernel parameters amy work such as turning power save off.