Wifi disconnecting constantly

I’m on EoS latest!
all packages are up to date
the command journalctl -p 3 -xb gives me this error ( only this error)
‘‘wpa_supplicant[709]: bgscan simple: Failed to enable signal strength monitoring’’

I have continuous disconnections from my line !
I can only solve it momentarily by rebooting the pc ( but then on reboot the problem recurs )
I am using mate as a DE!
Some additional info regarding the pc in question:
Kernel: 6.7.9-arch1-1 arch: x86_64 bits: 64
Desktop: MATE v: 1.26.2 Distro: EndeavourOS
Type: Laptop System: TOSHIBA product: Satellite Pro C660 v: PSC0RE-02200RIT
UEFI-[Legacy]: TOSHIBA v: 1.80 date: 05/17/11
Info: dual core model: Intel Core i3 M 380 bits: 64 type: MT MCP cache:
L2: 512 KiB
Speed (MHz): avg: 1065 min/max: 933/2533 cores: 1: 1463 2: 933 3: 933
4: 933
Device-1: Intel Core Processor Integrated Graphics driver: i915 v: kernel
Device-2: Chicony CNF9055 Toshiba Webcam driver: uvcvideo type: USB
Display: x11 server: X.Org v: 21.1.11 driver: X: loaded: modesetting
dri: crocus gpu: i915 resolution: 1366x768~60Hz
API: EGL v: 1.5 drivers: crocus,swrast platforms: x11,surfaceless,device
API: OpenGL v: 4.5 compat-v: 2.1 vendor: intel mesa v: 24.0.2-arch1.2
renderer: Mesa Intel HD Graphics (ILK)
Device-1: Intel 5 Series/3400 Series High Definition Audio
driver: snd_hda_intel
API: ALSA v: k6.7.9-arch1-1 status: kernel-api
Server-1: PipeWire v: 1.0.3 status: active
Device-1: Realtek RTL8188CE 802.11b/g/n WiFi Adapter driver: rtl8192ce
IF: wlan0 state: up mac:
Local Storage: total: 596.17 GiB used: 48.42 GiB (8.1%)
ID-1: /dev/sda vendor: Toshiba model: MK6475GSX size: 596.17 GiB
ID-1: / size: 588.2 GiB used: 48.42 GiB (8.2%) fs: btrfs dev: /dev/sda1
ID-2: /home size: 588.2 GiB used: 48.42 GiB (8.2%) fs: btrfs
dev: /dev/sda1
ID-3: /var/log size: 588.2 GiB used: 48.42 GiB (8.2%) fs: btrfs
dev: /dev/sda1
ID-1: swap-1 type: partition size: 7.97 GiB used: 0 KiB (0.0%)
dev: /dev/sda2
System Temperatures: cpu: 47.0 C mobo: N/A
Fan Speeds (rpm): N/A
Memory: total: 4 GiB note: est. available: 3.63 GiB used: 1.3 GiB (35.9%)

Any ideas on how to remedy and solve?


Anyone who could tell me a solution?

even of a workaround would be good

Hello, :slight_smile:

To start you on, I did a search ;

There’s a couple of articles and videos for wpa_supplicant :

Can you physically try a rj-45 cable ?

At least you would be in Full duplex instead of slowing down on Wifi. A quick “plaster” to help you experiment with your configs to make that Half duplex dial in.

Of course, knowledgeable members with experience might point you in a faster direction :wink:

You could try the AUR package rtw88-dkms-git

I apologize if I reply with some delay and thank you for the info but I forgot to write that both arch references and your advice did not solve my problem!

I wrote here precisely because all attempts have not brought positive effects

Edit: Try this then.

Make a file in /etc/modprobe.d/rtl8192ce.conf


options rtl8192ce ips=0 fwlps=0

yes I had already edited the file

Did you reboot to see if it made any difference?

Edit: You could try these then.

Disable powersaving
options rtl8192ce ips=0

Use software control
options rtl8192ce swlps=1

I also created the wpa_supplicant.conf file in etc/wpa_suplicant with the text: bgscan=“simple:30:-70:3600” but I am not sure if the syntax is right

and even then I didn’t solve anything!

not this no
( Use software control
options rtl8192ce swlps=1) now i will try right away

no, it doesn’t solve anything

the bgscan parameter be added to the wpa_supplicant.conf file or in another path?

i’ll try it to see if i solve

I’m not sure about what you are trying. Are you using Network Manager may not need wpa_supplicant running.

Edit : I checked on Kde

[ricklinux@rick-ms7c37 ~]$ systemctl status wpa_supplicant
● wpa_supplicant.service - WPA supplicant
     Loaded: loaded (/usr/lib/systemd/system/wpa_supplicant.service; disabled; preset: disabled)
     Active: active (running) since Thu 2024-03-14 15:12:43 EDT; 7min ago
   Main PID: 1327 (wpa_supplicant)
      Tasks: 1 (limit: 38385)
     Memory: 5.9M (peak: 6.4M)
        CPU: 432ms
     CGroup: /system.slice/wpa_supplicant.service
             └─1327 /usr/bin/wpa_supplicant -u -s -O /run/wpa_supplicant

Mar 14 15:12:43 rick-ms7c37 systemd[1]: Starting WPA supplicant...
Mar 14 15:12:43 rick-ms7c37 systemd[1]: Started WPA supplicant.
Mar 14 15:12:43 rick-ms7c37 wpa_supplicant[1327]: Successfully initialized wpa_supplicant
Mar 14 15:12:44 rick-ms7c37 wpa_supplicant[1327]: dbus: fill_dict_with_properties dbus_interface=fi.w1.wpa_>
[ricklinux@rick-ms7c37 ~]$ 

I guess you are referring to this?


Have you tried?

sudo systemctl restart NetworkManager