WiFi - Device Not Ready

After system update, wifi stopped working. No WiFi networks are showing.


I had installed this driver earlier to make it work " 8188fu-kelebek333-dkms-git".
But after update it is not working. Please help.

Looks like this driver breaks every upgrades or so. I saw a similar post on the Arch wiki from January.


Maybe try lts kernel.

1 Like

Have you tried the other package?

yay -S 8188fu-dkms-git

Thanks for the reply… I am using Lts Kernel only. I tried the command to blacklist as mentioned in the post you shared… No luck… Still facing the same issue.

Thanks for the reply. Tried it… I got some error logs while installing.
Sharing the screenshot here.

But i think the package is installed. I can see it in the GUI. But still issue is there.

Do you have the lts kernel headers installed? It’s giving that error can’t find.

Shall I install this ?

Did you have the lts kernel headers installed previously? If not install them and or try reinstalling them?

sudo pacman -S linux-lts-headers
1 Like

Thanks Rick… It worked.
I ran “sudo pacman -S linux-lts-headers” and reinstalled " 8188fu-kelebek333-dkms-git".

Now available WiFi connections are showing. :smiley:

1 Like

Where are everyone’s manners today?

Welcome to the EndeavourOS forum. I hope you enjoy your time here.

As you have already seen, the forum is friendly and helpful.


hello @Vicky

welcome to the purple universe :enos: :enos_flag: :penguin_face: :rocketa_purple:

Sorry sometimes i don’t realize a new user or forget my manners. :pleading_face:

Welcome @Vicky
Glad you got it working again.

No worries. As much as you do on the forum, it is easy to miss something.


1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.