WiFi connected no internet

I’ve just tried this out it’s a great os way better than my last manjaro any how I was using the WiFi and turned computer off over lunch when I came back to use it, it would connect but there was no internet I have no clue what the problem is but ice had the issue across multiple devices and distros so I’m really lost as the internet always seems to kill itself eventually even if I seemingly do nothing.
Please keep any explanations simple as I’ve only just started learning to deal with konsole/terminal stuff
Please help

Have you looked at the router or access point?

Won’t connect to any network I’ve tried multiple and I was on a network the other people had no problem with just my laptop

It sounds like a hardware issue. You could post the output of inxi -Faz (as text), or buy a more compatible WiFi adapter.


Your Wifi chipset has this known issue, as @jonathon already hinted.

On the net, I found two solutions, you can try.

First, the simpler one:

Secondly, a more complicated approach:

Good luck!

Thanks this looks like it might work but i started following this guide and i don’t know how to fix this issue sorry if its something really stupid but i am really unfamiliar with the konsole

There is no need to log in as root. If you want to edit or make the configuration file rtl8822be-blacklist.conf just type sudo nano /etc/modprobe.d/rtl8822be-blacklist.conf or use an editor of your choice.

Ok I’ve got Futher along but it’s asking me to start installing drivers one by one but I can’t do not as this device won’t connect to the internet what am I supposed to do?
It fails on this:
sudo pacman -Syu rtw88-dkms-git

Failed retrieving file from mirror
Failed to synchronize all databases library error
What can I do past this?

Why did you not try the easier, first solution I gave you?
Now you’re trying the much more complicated one.

The first one only needs to add a kernel parameter to Grub_Cmd_Line_Linux in /etc/grub/grub.cfg, then update grub before a reboot. No Wifi necessary.

For the second solution I posted, the best chance of fixing your system with internet up and running would be to chroot into EnOS from a live ISO and do the installation from there, as your WiFi must have worked during the first insallation from a live ISO before.

I think I was having issues with the first one,
Sorry this is probably the hardest thing I’ve had to fix so I’m just I bit lost but thanks for the tips