Wifi, bluetooth, and DNS issues

Wifi card chipset: AX200
Wifi driver: iwlwifi

I’ve been having issues with my internet. It gets really inconsistent performance, either below average but bearable to way above average to completely unusuable. It turns on a dime, and it’s frustrating. Googling and reading threads made about this in the past didn’t help, unfortunately. Another thing is my bluetooth has been acting up. My wifi card comes with bluetooth, and I have tried using it, however, when sending ANY file over via bluetooth, it either fails or immediately disconnects, as well as bluetooth devices not properly connecting to my PC.

Hello @ridersoftheworm

You could try adding the following to /etc/modprobe.d/iwlwifi.conf

options iwlmvm power_scheme=1
1 Like

My /modprobe.d/ folder is empty

Then create the file iwlwifi.conf in the folder.

2 Likes

You could try adding the following to /etc/modprobe.d/iwlwifi.conf

options iwlmvm power_scheme=1

Thank you for responding. I tried this, and it unfortunately didn’t work. I ran “journalctl | grep bluetooth” to get this for you:

Sep 03 19:09:05 user-mxxxx NetworkManager[648]: [1599185345.0556] Loaded device plugin: NMBluezManager (/usr/lib/NetworkManager/1.26.2-1/libnm-device-plugin-bluetooth.so)
Sep 03 19:09:05 user-mxxxx bluetoothd[842]: Bluetooth daemon 5.54
Sep 03 19:09:05 user-mxxxx audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 msg=‘unit=bluetooth comm=“systemd” exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success’
Sep 03 19:09:05 user-mxxxx bluetoothd[842]: Starting SDP server
Sep 03 19:09:05 user-mxxxx kernel: audit: type=1130 audit(1599185345.931:29): pid=1 uid=0 auid=4294967295 ses=4294967295 msg=‘unit=bluetooth comm=“systemd” exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success’
Sep 03 19:09:05 user-mxxxx bluetoothd[842]: Bluetooth management interface 1.17 initialized
Sep 03 19:09:15 user-mxxxx plasmashell[1428]: file:///usr/share/plasma/plasmoids/org.kde.plasma.bluetooth/contents/ui/DeviceItem.qml:208: TypeError: Cannot assign to read-only property “status”
Sep 03 19:09:15 user-mxxxx plasmashell[1428]: file:///usr/share/plasma/plasmoids/org.kde.plasma.bluetooth/contents/ui/DeviceItem.qml:46:5: Unable to assign [undefined] to bool
Sep 03 19:24:13 user-mxxxx plasmashell[1428]: file:///usr/share/plasma/plasmoids/org.kde.plasma.bluetooth/contents/ui/DeviceItem.qml:46:5: Unable to assign [undefined] to bool
Sep 03 19:24:13 user-mxxxx plasmashell[1428]: file:///usr/share/plasma/plasmoids/org.kde.plasma.bluetooth/contents/ui/DeviceItem.qml:208: TypeError: Cannot assign to read-only property “status”
Sep 03 19:24:13 user-mxxxx plasmashell[1428]: file:///usr/share/plasma/plasmoids/org.kde.plasma.bluetooth/contents/ui/DeviceItem.qml:46:5: Unable to assign [undefined] to bool
Sep 03 19:24:13 user-mxxxx plasmashell[1428]: file:///usr/share/plasma/plasmoids/org.kde.plasma.bluetooth/contents/ui/DeviceItem.qml:208: TypeError: Cannot assign to read-only property “status”
Sep 03 19:24:13 user-mxxxx plasmashell[1428]: file:///usr/share/plasma/plasmoids/org.kde.plasma.bluetooth/contents/ui/DeviceItem.qml:46:5: Unable to assign [undefined] to bool
Sep 03 19:24:17 user-mxxxx plasmashell[1428]: file:///usr/share/plasma/plasmoids/org.kde.plasma.bluetooth/contents/ui/FullRepresentation.qml:121:13: Unable to assign [undefined] to QQuickAction*
Sep 03 19:24:27 user-mxxxx plasmashell[1428]: file:///usr/share/plasma/plasmoids/org.kde.plasma.bluetooth/contents/ui/FullRepresentation.qml:121:13: Unable to assign [undefined] to QQuickAction*
Sep 03 19:24:27 user-mxxxx plasmashell[1428]: file:///usr/share/plasma/plasmoids/org.kde.plasma.bluetooth/contents/ui/FullRepresentation.qml:121:13: Unable to assign [undefined] to QQuickAction*
Sep 03 19:24:33 user-mxxxx plasmashell[1428]: file:///usr/share/plasma/plasmoids/org.kde.plasma.bluetooth/contents/ui/FullRepresentation.qml:121:13: Unable to assign [undefined] to QQuickAction*
Sep 03 19:24:34 user-mxxxx plasmashell[1428]: file:///usr/share/plasma/plasmoids/org.kde.plasma.bluetooth/contents/ui/FullRepresentation.qml:121:13: Unable to assign [undefined] to QQuickAction*
Sep 03 19:24:41 user-mxxxx plasmashell[1428]: file:///usr/share/plasma/plasmoids/org.kde.plasma.bluetooth/contents/ui/FullRepresentation.qml:121:13: Unable to assign [undefined] to QQuickAction*
Sep 03 19:24:50 user-mxxxx bluetoothd[842]: a2dp-sink profile connect failed for 50:18:06:94:CF:EB: Protocol not available
Sep 03 19:24:55 user-mxxxx plasmashell[1428]: file:///usr/share/plasma/plasmoids/org.kde.plasma.bluetooth/contents/ui/FullRepresentation.qml:121:13: Unable to assign [undefined] to QQuickAction*
Sep 03 19:24:58 user-mxxxx plasmashell[1428]: file:///usr/share/plasma/plasmoids/org.kde.plasma.bluetooth/contents/ui/FullRepresentation.qml:121:13: Unable to assign [undefined] to QQuickAction*

Not sure if you installed any of the Bluetooth?

2 Likes

There are some more configuration setting’s you can make for the iwlwifi.

https://wiki.archlinux.org/index.php/Network_configuration/Wireless#iwlwifi

Not sure if you installed any of the Bluetooth?

I have Bluez installed.

Unfortunately, I think it’s something out of our hands, as at this point, I’ve tried everything, and I’ve read many threads where people have complained that nothing has worked for them. Thank you for trying to help, though. I appreciate it. I do find the wiki’s wording of the issue amusing:

Others found salvation by disabling N in their router settings after trying everything.

Yes that was one of the conf file settings to disable n. I wouldn’t do it from the router because you may have other devices that use it such as cell phone.

Glad that worked for you. Disabling N is okay if you have an AC router otherwise you’d be dropping down to G standard which is quite slower if it’s only an N router.