WIFI and BT hardblocked

first of all, I am new to Linux. My problem is that my WIFI and Bluetooth are hardblocked (rfkill list).
I am using a Thinkpad x220. It has a button to block the wireless connections (fn + f5). It seems that this cannot be unblocked.
I have “tried sudo rfkill unblock all” to solve the problem. Without success. Do you have any ideas?
Thank you!

Are you dual booting with windows? I had a problem where windows hibernates and then when I restart into linux I cannot start wifi.

This can happen if you don’t have Windows fast start up feature turned off in Windows 10 that uses hiber-file. So that is a possibility so i would turn that feature off in Windows 10 to start with.

Edit: Hard Block is the switch on the left side of the Thinkpad. x220

I did not notice the switch. I only bought the Thinkpad second-hand a few days ago. Thank you!
You guys are really helpfull. Thank you! :slight_smile:

Does that work for you?

Yes, solved it immediately

1 Like

You can mark it solved then if you could thanks.