Wifi 6E Card not recognized on old motherboard

Hi all,

I’m stumped. I’ve tried changing usb connectors, PCI slots, all the possible BIOS settings, even different linux distros, but my relatively new AX210 Wifi 6E card isn’t recognized on my Sabertooth P67.

This is the card

It’s not even listed when I run lspci. Is my motherboard too old? It’s from 2011 and runs Endeavour beautifully.

The wifi card works on my other Bazooka B550 out of the box, but no dice on my trusty P67.

Any help would be appreciated.

tried also with linux-lts ?


did you check in bios ? does it show on onboard device configuration or somewhere else?

I have an ancient BIOS last updated in 2012. It has options for PCI settings, but no, I do not see it in BIOS per se.

The boot log could tell a story…

journalctl -b -0 | eos-sendlog

I’m running the latest BIOS, build 3602, but here is a description of what I see, from 5:00 to sixish (1m) Asus Sabertooth P67 Review Part 3 of 3 BIOS - YouTube

Thanks. Here’s the output. I can’t make heads nor tails from this


What is the output of

lspci -k


You have three pci express 2.0x1 slots. Have you tried this card in each of them? It could be just an IRQ conflict.

I have tried all three. None recognized the card Never had an IRQ conflict with the Sabertooth before. I thought IRQ conflicts were a thing of the past :sweat_smile:

Do you have EHCI hand off enabled?

Edit: Also i wonder about this setting on the second pci-e X16 slot which changes the settings for the 1x slots.


No I hadn’t enabled EHCI hand-off.

I was going to ask about the PCI Express x1_2 Slot configuration. It was set at U3. Now it’s at X1. It’s on the first, top slot. I’ll change it to the second.

I also disabled the serial port, so it doesn’t take up an IRQ

All you can do is try these settings and the slots and see if it makes any difference.

It’s on the second slot in X1 mode, still no dice with EHCI hand-off enabled. Is the card even compatible with such an old motherboard?

It’s a pci-e 1x so it should be.

Thanks for the advice, but it’s still not working. The USB connector is plugged in too, for bluetooth, and I’m not getting bt either. I’m still stumped.

Here’s the present journalctl -b -0 | eos-sendlog


i do not see a single hint in the logs its like it is not plugged in at all…


rfkill list all

and it really does not show on any of the tools?

inxi -Na

What does this show also. Post the link.

sudo dmesg | eos-sendlog