Who do I have these 2 options at Boot?

Hi, I’m new to endeavouros and when I start my PC I always see these 2 options. I don’t want to see this screen at every boot. How can I disable it?

I’ve installed Atlantis Neo XFCE.


This is correct. But if you want to bypass this i think you can?

Edit: I was waiting for @freebird54 to respond. :thinking:

1 Like

Well - there are several ways of avoiding it - some ‘wiser’ than others. One way is to boot with another method than grub (which is the screen you show) such as systemd boot - or rEFInd. A look through our wiki (menu at the top of our forum) will give you more on that…

Other than that, you can skip this screen entirely - but you risk being unable to recover easily if something goes wrong. (You get into having to arch-chroot from a live ISO and that can a bit complicated compared to having that screen for 1 sec (which is also a setting you can change to).

After taking a look at the alternatives - if help is needed we casn supply it usually! ;grin:

You could use rEFInd but instead of the grub menu you would have an icon to boot from which boots from vmlinuz-linux image file.

Edit" I’m not sure what you want. You could lower the timeout in the grub menu so it boots faster. As @dalto just beat me to it!

Edit /etc/default/grub and set the timeout to 0.

Then run:

sudo grub-mkconfig -o /boot/grub/grub.cfg

@freebird54 said

but you risk being unable to recover easily if something goes wrong.

Can I still do the command without any issues? I’m asking because I’m a Newbie.

Normally you should be able to make Grub boot menu to show again by pressing SHIFT or ESC keys after you power up your machine.


I changed the timeout to 0 but it won’t let me save the file.

It is owned by root.

If the editor you are using doesn’t support escalation, you can do it from the terminal.

sudo nano /etc/default/grub
1 Like

How do I save?



It should ask you if you want to save

1 Like

I also did the command:

[orbital@orbital-m32cd ~]$ sudo grub-mkconfig -o /boot/grub/grub.cfg
[sudo] password for orbital: 
Generating grub configuration file ...
Found theme: /boot/grub/themes/EndeavourOS/theme.txt
Found linux image: /boot/vmlinuz-linux
Found initrd image: /boot/initramfs-linux.img
Found fallback initrd image(s) in /boot:  initramfs-linux-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Adding boot menu entry for UEFI Firmware Settings ...
[orbital@orbital-m32cd ~]$ 

@dalto I restarted and it worked. Thank you very much everyone.


Easy peasy!


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.