White underline at boot. (Dualboot/Grub)

Hi, ive got a white underline (blinking) with nothing happening when booting my tower regularly.
Ive got Dual Boot with Windows and EOS. This problem wasnt there before it just came out of nowhere.

I can still boot by pressing F12 at the very beep of my Tower to go into the Bootmenu and Select either EOS or Windows. By selecting EOS i get into grub and from there into EOS.

Is there any possibility to fix ths without completely reinstalling?

Thanks in advance.

Perhaps the following info may help someone to figure out what is going on.

Post the output of:


sudo parted -l

lsblk -f

cat /etc/fstab

❯ efibootmgr
BootCurrent: 0005
Timeout: 1 seconds
BootOrder: 0005,0004,0003,0001,0000,0002
Boot0000* ST31000524AS BBS(17,0x0)
Boot0001* EFI: Hard Drive PciRoot(0x0)/Pci(0x1f,0x2)/EDD10(0x2a010480)/HD(1,GPT,3bb1d610-8e08-4bbd-b6c3-a7fba31d39c6,0x800,0x32000)
Boot0002* P0: ATAPI DVD A DH16ABSH BBS(18,0x0)
Boot0003* Windows Boot Manager HD(1,GPT,3bb1d610-8e08-4bbd-b6c3-a7fba31d39c6,0x800,0x32000)/\EFI\Microsoft\Boot\bootmgfw.efi57494e444f5753000100000088000000780000004200430044004f0042004a004500430054003d007b00390064006500610038003600320063002d0035006300640064002d0034006500370030002d0061006300630031002d006600330032006200330034003400640034003700390035007d00000000000100000010000000040000007fff0400
Boot0004* Windows Boot Manager HD(1,GPT,3bb1d610-8e08-4bbd-b6c3-a7fba31d39c6,0x800,0x32000)/\EFI\Microsoft\Boot\bootmgfw.efi57494e444f5753000100000088000000780000004200430044004f0042004a004500430054003d007b00390064006500610038003600320063002d0035006300640064002d0034006500370030002d0061006300630031002d006600330032006200330034003400640034003700390035007d00000000000100000010000000040000007fff0400
Boot0005* endeavouros HD(1,GPT,3bb1d610-8e08-4bbd-b6c3-a7fba31d39c6,0x800,0x32000)/\EFI\endeavouros\grubx64.efi

Model: ATA ST31000524AS (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 1049kB 106MB 105MB fat32 EFI system partition boot, esp, no_automount
2 106MB 123MB 16,8MB Microsoft reserved partition msftres, no_automount
3 123MB 575GB 575GB ntfs Basic data partition msftdata
4 575GB 576GB 792MB ntfs hidden, diag, no_automount
5 576GB 675GB 98,9GB ntfs Basic data partition msftdata
6 675GB 1000GB 325GB btrfs endeavouros

Warning: Unable to open /dev/sr0 read-write (Read-only file system). /dev/sr0
has been opened read-only.
Model: ATAPI DVD A DH16ABSH (scsi)
Disk /dev/sr0: 7097MB
Sector size (logical/physical): 2048B/2048B
Partition Table: loop
Disk Flags:

Number Start End Size File system Flags
1 0,00B 7097MB 7097MB udf

├─sda1 vfat FAT32 3C0E-612D 69,2M 28% /boot/efi
├─sda3 ntfs 9212A7A612A78E33
├─sda4 ntfs 72FC5971FC593119
├─sda5 ntfs Volume 9CC838F9C838D2EE
└─sda6 btrfs endeavouros a86b6c3f-9d7a-464c-8ab6-3e4addb4506d 288,6G 4% /home
sr0 udf 1.02 LO4-0E-FT1_DES 554e444546494e45

/etc/fstab: static file system information.

Use ‘blkid’ to print the universally unique identifier for a device; this may

be used with UUID= as a more robust way to name devices that works even if

disks are added and removed. See fstab(5).

UUID=3C0E-612D /boot/efi vfat fmask=0137,dmask=0027 0 2
UUID=a86b6c3f-9d7a-464c-8ab6-3e4addb4506d / btrfs subvol=/@,noatime,compress=zstd 0 0
UUID=a86b6c3f-9d7a-464c-8ab6-3e4addb4506d /home btrfs subvol=/@home,noatime,compress=zstd 0 0
UUID=a86b6c3f-9d7a-464c-8ab6-3e4addb4506d /var/cache btrfs subvol=/@cache,noatime,compress=zstd 0 0
UUID=a86b6c3f-9d7a-464c-8ab6-3e4addb4506d /var/log btrfs subvol=/@log,noatime,compress=zstd 0 0

I KNOW my partitioning is a mess but i cant be bothered to fix it and it has worked like a charm before lol

Nothing jumps immediately out as being off with the output you have posted.

You could however try reinstalling the grub’s binary efi bootloader and regenerate grub.cfg.

I cannot guarantee that it will resolve the issue which may be caused by something else but it won’t hurt trying.

From your current EnOS session, run:

sudo grub-install --efi-directory=/boot/efi bootloader-id=endeavouros


sudo grub-mkconfig -o /boot/grub/grub.cfg


It the issue is still there, I’m afraid I couldn’t be of more help and will be watching knowledgeable forum members to assist you further.

Sadly this hasnt changed anything at all. but thank you anyways. maybe someone has an idea too!
it kinda feels like grub is in the wrong place when booting. why doesnt access my pc grub right away or maybe cant, but via the boot menu from the mainboard i can acess ist, when choosing endavouros entry in there.

feels weird. i dont remember getting to grub when choosing endavour os from the mainboard boot menu, but maybe thats just me. lol

Hopefully some members will come by who have a better idea of what might be the cause.

Thereby, I withdraw and wish you good luck on resolving this issue.

Another option would be to check the boot order from within computer’s BIOS.

On my laptop after a BIOS update it got stuck at the BIOS logo. The bootorder I changed via efibootmgr -o … had no effect until I “resorted” things from within BIOS.

Maybe this helps.


THIS WAS IT. I went into the Bios and checked the Loadorder and EOS were at the very bottom for some reason.
Thank you.

1 Like