While trying to get Japanese input working, something screwed up how some f strings display in my Nimbus Mono font

I tried installing fcitx5 with the wiki using the fcitx5-im group to get Japanese input. I’m used to using Japanese input on Windows 10 and couldn’t get a dropdown list of suggestions to appear as I typed romaji and decided to uninstall everything and try again later. I also installed the otf-ipafont.

Turns out, something happened to my Nimubs Mono font and strings of “ff”, “fi”, & “fl” will cause the 2 letters to shrink together a little bit even when typed in the middle of a word. In a console window, this also has a side effect of leaving what appears to be extra space after the containing string for each occurrence of the 3 problematic substrings when it’s really only a single space.

Does anyone have any idea how to fix this?

@zecuse This seems to work: https://ostechnix.com/setup-japanese-language-environment-arch-linux/ This is Anthy.
Actually I don’t understand what happened to Nimbus Mono. I’d uninstall some latest new packages.
Choose a free shortcut to change keyboard in Ibus preferences. Super+space e.g.
Then space can be used to open scroll-down menu to select a kanji.

But the question was not that.