Where exactly does YAY install packages?

I understand that if you build a package from source you need to go into its directory before you can run it. For example I installed sagemath in a directory named sage-9.2. To run sage you need to type ./sage, but this only works if I cd into that directory. I installed both extcalc and miktex using yay but they don’t even show up in my system, it’s like I didn’t even install them? I can’t run miktexsetup. I ran locate -e miktex and nothing shows up (but if I run yay -Qs miktex it says I have it installed).

yay just builds a normal package and then installs it using alpm/pacman. Once a package is installed by yay it can be located like any other package.

If you want to see a list of the files installed by a package, you can use:

yay -Ql packagename

For that matter, you could use:

pacman -Ql packagename

You probably just need to type sage

The command ./sage literally means rune the binary sage from the current directory.

When used in a file path, the . means “the current directory”

It looks like it creates a menu entry called miktex-console. You could look at that and see what the name of the binary it is running is.


in addition you will find each builded package from yay under ~/.cache/yay and you can set /etc/makepkg.conf to store builded packages in a folder of your choice:

Also, https://wiki.archlinux.org/index.php/Frequently_asked_questions#I_just_installed_Package_X._How_do_I_start_it?

The post referenced above has a ‘proper’ way to find out. Some of us lesser mortals try our best guess from the terminal:

which programname

using your guess from above - such as which extcalc or which miktex. That way, if it returns an answer, you will know one way to run it - and where it is located! A typical result would be /usr/bin/programname

1 Like

You probably just need to type sage

No, if I type sage in my home directory then nothing happens. Although, I forgot to mention that I compiled sagemath from source, not from the official repos, so that’s probably the reason sage doesn’t work.

You were right, there was an entry named miktex-console in my menu; I went through the installation process and updated it but alas, my system could not recognize the pdflatex command. I uninstalled miktex and installed texlive-most (I understand that this attitude is not really in the spirit of linux but I’ve been tackling linux-related problems for quite some days now and I think I need to take a break).

Also is there a limit to how many replies in a standard time frame I can give in this forum? It would be nice to reply to all people in one sitting.

The title of your topic is “Where exactly does YAY install packages?” So I thought we were talking about packages built using yay. If you manually build a package from source then your options are a little different:

  • Add it to your path somehow. Lets of ways to do this but common ways include putting a symlink somewhere in your path or actually adding the directory the program is in to your path.
  • Specify the full path when you execute the program like this: /path/to/sage
  • cd into the directory and type ./sage

You don’t need to use multiple replies. You can quote multiple message in single reply. When you are editing a reply. Highlight the text you want to reply to and click quote. That will be appended into your open reply.

Yes sorry I forgot that I had compiled sage from source at the time of making this topic. Sorry. Thanks for the help.

What does alpm mean in this context? It doesn’t stand for ‘advanced link power management’, does it?

Thank you.


Haha then I guess I should choose the way of a mere mortal!

libalpm (Arch Linux Package Management) is pacman’s library.

1 Like

Until you ascend, at least. :wink:

1 Like