Where did Qt Designer go?

I remember at one point in time installing the latest version of EndeavourOS and it came pre-installed with Qt Designer, which at the time was a huge plus for me as sometimes it’s a pain to get it installed on Arch based systems.

Reinstalled recently and I noticed something - while Qt Designer was present in the live environment; after install it seems to have disappeared. Not sure if this is intentional or not, but it’s something I’d like to keep with my install(s). Iirc correctly it usually comes bundled when pip installing pyqt5-tools but I always seem to run into issues with that method, and the Qt Installer never lists it as a standalone option so I usually shy away from it.

I know that I can get it bundled with the pyside6 pip install, which is fine - if that’s what I have to do, then issue resolved. But if I could get further clarification on the matter, such as if this is an intentional choice, or if there’s other easier and / or cleaner ways to install the media; then it would be greatly appreciated.

It should be easy to install. It is part of qt5-tools and/or qt6-tools. You don’t need to install pyside6 and if you used sudo pip to install it you should definitely reverse that or your system will be in a bad spot.

Depending on which DE you installed and which applications were selected in the installer, it may have included as a dependency.

1 Like

I’m aware that it’s bundled with the qt5-tools / qt6-tools installation, but when attempting that I keep running into errors such as the ibQt5Designer.so.5 dependency not existing. It’s just a pain that I keep running into which is why I was seeking other possible methods and / or fixes to the problem.

On a side note: I did not sudo pip install pyside6 - I set up a contained environment with a local user installation of pyside6 to see if the designer came bundled, and actually worked. It did. This just isn’t the method I would prefer to acquire it, and if there are better alternatives then I would like to pursue those first before falling back on a pyside6 installation.

For the installation methods of the OS, I just did the same thing I did the last time I installed EndeavourOS. I did the offline install which gives XFCE, and that kept Qt Designer the last time I did it. Now it no longer keeps it.

This shouldn’t happen. We should figure out what is going on. That usually means you are in a partial update situation.

Any suggestions on what course of action I should take to diagnose the issue?

Run sudo pacman -Syu qt5-tools

If it still doesn’t work after that, run it from a terminal and post the output here.

The most common cause for an issue like that is you tried to install software without updating the system.


Yep, that worked. My problem was I forgot that qt5-tools was an actual package and did pip install qt5-tools instead of the proper pacman installation. This resulted in a malformed Python package instead of the actual dependencies and program being installed. So that’s a mess-up on my part. Thank you!


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.