When left idle, Endeavour shuts down and have to unplug computer to restart/

It won’t restart without a reboot and unplugging the computer/ That’s a first for me. I think I asked for no hibernate but maybe not.

Never do that, you’ll just mess up your filesystem.

Enable the Magic SysRQ key and use that to restart the computer.


Regarding your original issue, check that your swap file or partition is large enough to hold the entire contents of RAM, plus more (if your system is swapping a lot). That is necessary for your system to be able to hibernate.

If you don’t want your computer to hibernate, then disable it.

1 Like

Can you post the specs? Cuz it sounds like your PC does not wake up from sleep/hibernate

This happens with multiple arch based destros. Magic SysRq Key, gee I wish that would work.
System:
Host: ja-systemproductname Kernel: 5.10.73-1-lts x86_64 bits: 64
compiler: gcc v: 11.1.0 Desktop: GNOME 40.5 Distro: EndeavourOS
base: Arch Linux
Machine:
Type: Desktop Mobo: ASUSTeK model: M4N68T-M-V2 v: Rev X.0x
serial: BIOS: American Megatrends v: 0702
date: 01/26/2011
CPU:
Info: Triple Core model: AMD Athlon II X3 455 bits: 64 type: MCP arch: K10
rev: 3 cache: L2: 1.5 MiB
flags: lm nx pae sse sse2 sse3 sse4a svm bogomips: 19890
Speed: 3300 MHz min/max: 800/3300 MHz Core speeds (MHz): 1: 3300 2: 3300
3: 800
Graphics:
Device-1: NVIDIA GT218 [GeForce 210] vendor: eVga.com. driver: nouveau
v: kernel bus-ID: 02:00.0
Display: wayland server: X.org 1.20.13 compositor: gnome-shell driver:
loaded: nouveau note: n/a (using device driver) - try sudo/root
resolution: <missing: xdpyinfo>
Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
Device-1: NVIDIA MCP61 High Definition Audio vendor: ASUSTeK M4N68T series
driver: snd_hda_intel v: kernel bus-ID: 00:05.0
Device-2: NVIDIA High Definition Audio vendor: eVga.com.
driver: snd_hda_intel v: kernel bus-ID: 02:00.1
Sound Server-1: ALSA v: k5.10.73-1-lts running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: yes
Sound Server-4: PipeWire v: 0.3.38 running: no
Network:
Device-1: NVIDIA MCP61 Ethernet vendor: ASUSTeK M4N68T series
type: network bridge driver: forcedeth v: kernel port: d480
bus-ID: 00:07.0
IF: enp0s7 state: down mac: f4:6d:04:63:6f:b9
Device-2: ASIX AX88772 type: USB driver: asix bus-ID: 1-1:2
IF: enp0s2f1u1 state: up speed: 100 Mbps duplex: full
mac: 00:0e:c6:bc:e5:e7
Drives:
Local Storage: total: 614.82 GiB used: 16.92 GiB (2.8%)
ID-1: /dev/sda vendor: Seagate model: ST3100011A size: 93.16 GiB
ID-2: /dev/sdb vendor: Toshiba model: TR150 size: 223.57 GiB
ID-3: /dev/sdc type: USB vendor: Maxone model: USB 3.0 size: 298.09 GiB
Partition:
ID-1: / size: 25.51 GiB used: 8.32 GiB (32.6%) fs: ext4 dev: /dev/sda2
Swap:
Alert: No swap data was found.
Sensors:
System Temperatures: cpu: 30.0 C mobo: 33.0 C gpu: nouveau temp: 53.0 C
Fan Speeds (RPM): cpu: 867 case-1: 1445
Power: 12v: 11.88 5v: N/A 3.3v: 3.28 vbat: N/A
Info:
Processes: 186 Uptime: 1h 6m Memory: 3.84 GiB used: 1.73 GiB (45.1%)
Init: systemd Compilers: gcc: 11.1.0 Packages: 843 Shell: Bash v: 5.1.8
inxi: 3.3.06
[ja@ja-systemproductname ~]$

How do you disable hibernate. I’ve had a hard time putting arch backed distros on hard drives , I was following a suggested way to do it and it looks like that way left me without a swap file. So before I disable hibernate , I would like to ad the swap file to my partition. Again how is that done.

Edit the file /etc/sleep.conf and add the following to it:

AllowHibernation=no
AllowHybridSleep=no
AllowSuspendThenHibernate=no

(you can just uncomment the entries there and make sure they are set to no).

Also, in /etc/logind.conf you can set

HibernateKeyIgnoreInhibited=no
1 Like