When I type, the keyboard does extra inputs

GPU: NVIDIA Geforce GTX 1050 Ti, CPU: Ryzen 5 5600X, DE: Xfce 4.18, Keyboard: Generic wired Bloody keyboard with 113 keys (don’t remember the name)
Whenever I type fast enough the keyboard starts making weird things on specific occasions, for example if I type “cer” it just gives out cecer, and so on. On Windows I don’t have that problem, so I suppose it’s a compatibility glitch between the keyboard and the operating system, I could be wrong though.

Try a different keyboard.

And did you increase Repeat delay / decrease speed at Keyboard / Behavior / Typing Settings ?