When does terminal refuse $ in command?

the first command went through with a $, but I believe I was in root when I did that one.

Terminal has me in sudo now. I went through welcome, so there should be nothing with that to hold it back. at first I tried the second command with the $ in front, but eventually I tried it without, and it wants me to say Y/N. The official site says to have the sign for endeavouros to do a quick setup for flatpak. so I don’t see it as a typo?

So what is terminal doing?

The real question is what are the commands you are entering?

Edit: https://flatpak.org/setup/EndeavourOS


$ sudo pacman -Syu

$ sudo pacman -S flatpak

when the second one hadn’t been working, I tried

sudo pacman -S flatpak

,but it looks like just now when I tried to copy from the site it didn’t include the $. So maybe that was just me. Did it just let it go through the first command because I was in root? Did root just kind of figure it out in that case?

You don’t put a $ in there. That is part of the command prompt for a user.

Edit: You don’t use root. sudo elevates the command privileges.

sudo pacman -S flatpak

Edit: Please read about the package manager pacman


1 Like

gotchya, I see.
Thankyou so much :slight_smile:

This is user prompt
[ricklinux@rick-ms7c37 ~]$

This is root
[root@rick-ms7c37 ricklinux]#

1 Like

thank you

Never, never copy and run terminal commands from random sites, without first completely understanding what they do.

Many of these sites are written by complete idiots (this is particularly true of many “content creators” on YouTube), many of these resources are outdated or do not apply to a particular distro, and some are downright malicious.