What would cause a compositor to change numerical values midestream?

just asking for some hypotheticals/spitballing here, so I thank you in advance. I’m in lxde.
The mystery not killing me because I found a workaround, but it stays in my head as bizarre.

Situation for weeks: picom kept an app (plank) at 100% opacity its background by me using the digit 0= (zero) in the /.config folder picom.conf file. (see pic)

Situation now: 0= (zero) now restores the non-opaque background (see pic).
Because I haven’t changed this in the ~/etc folder yet, so I have to do this daily to make background opaque–change the 0 to 10 to go back to opacque.

why would a compositor suddenly need different numerical input and change numerical values, seemingly, out of nowhere?

edit for the tldr’s: why does it now take a 10 when it used to be 0?


apparently there is a history (and at least 9 pages) of Picom/Plank Glitchiness and numbers that change. I am closing this one. It would take me a couple hours to skim all the PPG bug issues.

I tried to understand the problem.
Installed plank and selected by CTRL+right-click Preferences Theme Transparent.
Installed picom and copied /etc/xdg/picom.conf to ~/.config/
Put picom and plank to ~/.config/lxsession/LXDE/autostart
Used default picom settings and it seems to work.

Last picom update was February, Plank was in 2022. If the apps didn’t change, it’s something else.
I did the same as @eso in Xfce and it works, I don’t understand why you specify a transparency value for Plank in picom.conf.

because xfce has an in-house compositor; lxde does not.