What dependencies do I need to get CSGO to launch with an Intel ARC GPU?


When I had an Nvidia GPU in my last PC, I was able to get CSGO to launch and perform flawlessly by running the command:

sudo pacman -S nvidia-settings nvidia-utils lib32-nvidia-utils lib32-opencl-nvidia opencl-nvidia libvdpau libxnvctrl vulkan-icd-loader lib32-vulkan-icd-loader

Now that I switched to an Intel ARC GPU, CSGO launches and crashes immediately. I can’t find what the equivalent to that command is that worked on Nvidia GPU for my new Intel ARC GPU.

Some help would be lovely. Thanks

Are you using vulkan-intel now? Instead of nvidia drivers? and lib32-vulkan-intel?

Yes correct. When installing steam, i chose the vulkan-intel options when prompted.

Have you enabled resize bar?

No, I have not. From my experiences with resize bar, I’ve always enabled it in the BIOS. I don’t remember seeing that option in my current BIOS.

Maybe check that as i think it should be enabled. :thinking:

Edit: Also did you swap out the nvidia card or this is a new system?

I’ll have to take a look at that.

This is a new system. I am using an Intel NUC 12 Enthusiast.

1 Like

Also are you using vulkan in the launch options?

I haven’t touched the launch options. I never needed to with the Nvidia GPU, so I assumed I can just leave it alone. I was told to use launch options when I had an Nvidia GPU as well, but that never actually helped. What helped is the command I shared with you in the original post. It seems that dependencies are missing, which is why CSGO crashes on EndeavourOS. At least that’s been my experience thus far.

I can’t find resize bar option in my BIOS.

What command? That is just for installing nvidia drivers if that’s what you are referring to? :thinking:

Yes correct. I mention that because when I had the previous PC with an Nvidia GPU, I installed EndeavourOS with the Nvidia drivers option, but I still had CSGO crashing just like my CSGO is crashing now.

That command in my original post installed additional files that made CSGO launch. I found that command here

Isn’t that what i meant it’s just for installing the nvidia drivers. If you installed EndeavourOS with the Intel card it should have the drivers required for Intel and the Intel ucode. The vulkan-intel would be the other needed. I would try using vulkan in the launcher however it is required. Supposedly that has worked for some? :thinking: I’m not a gamer nor do i have the Intel Arc gpu. Just trying to give you some things to try.

1 Like

Fair enough. So I just type vulkan in launch options? That’s it?

Edit: I think it needs to be: :thinking:



Well, I’ll be damned… “-vulkan” launch option worked. Thank you!

1 Like

Please mark the post that gave you the solution.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.