Welcome changes

Thank you for the changelog (I finally read it properly :sweat_smile: ) Just a suggestion, can in a some future version a link to endeavouros-team/PKGBUILDS/welcome github be added to it somewhere. I think it would be helpful.

1 Like

Do you mean this link? https://github.com/endeavouros-team/PKGBUILDS/tree/master/welcome
It could be added e.g. under the Help button in the Welcome app.

Out of curiosity: why would you want the link available inside Welcome? Or did I understand your suggestion correctly?

1 Like

Yes, this one.

I actually meant having it under ‘Welcome’s changelog’ button. So those interested in more details can quickly check the history of the commits.

3 Likes

Right, nice idea. I’ll add it to the changelog.
Edit: done.

4 Likes

@manuel
I just installed Deepin desktop and there is no welcome screen come up?

Edit: I just checked and it is there. Does it not automatically launch anymore? Also i don’t see it in the apps?

By default it should launch automatically. But do you have changes in the .desktop files?
Or did you try command:

   eos-welcome --enable

It comes up if you launch it from the terminal. But the icon is not in the apps and it doesn’t auto start.

Could you show the contents of files

  • /etc/xdg/autostart/welcome.desktop
  • /usr/share/applications/welcome.desktop
  • ~/.config/autostart/welcome.desktop

of all of them that exist.

[ricklinux@deepin-arch ~]$ cat /etc/xdg/autostart/welcome.desktop
[Desktop Entry]
Type=Application
Encoding=UTF-8
Name=Welcome
Comment=EndeavourOS Welcome launcher
Comment[sk]=Spúšťač privítania v systéme EndeavourOS
Exec=sh /usr/share/endeavouros/scripts/welcome --startdelay=3      # for autostart
#Exec=sh /usr/share/endeavouros/scripts/welcome --enable           # for desktop launcher
Icon=/usr/share/endeavouros/EndeavourOS-icon.png
# StartupNotify=false
# Terminal=False
Hidden=false
X-GNOME-Autostart-enabled=true
X-KDE-autostart-after=panel

[ricklinux@deepin-arch ~]$ 
[ricklinux@deepin-arch ~]$ cat /usr/share/applications/welcome.desktop
[Desktop Entry]
Type=Application
Encoding=UTF-8
Name=Welcome
Comment=EndeavourOS Welcome launcher
Comment[sk]=Spúšťač privítania v systéme EndeavourOS
#Exec=sh /usr/share/endeavouros/scripts/welcome --startdelay=3      # for autostart
Exec=sh /usr/share/endeavouros/scripts/welcome --enable           # for desktop launcher
Icon=/usr/share/endeavouros/EndeavourOS-icon.png
# StartupNotify=false
# Terminal=False
Hidden=false
X-GNOME-Autostart-enabled=true
X-KDE-autostart-after=panel

[ricklinux@deepin-arch ~]$ 
[ricklinux@deepin-arch ~]$ cat ~/.config/autostart/welcome.desktop
cat: /home/ricklinux/.config/autostart/welcome.desktop: No such file or directory
[ricklinux@deepin-arch ~]$ 

Edit: Looks like no auto start config? I don’t know how to find that on Deepin.

I found the empty folder.

I know it worked before but i haven’t tried deepin in a while and there have been a lot of changes with the welcome screen. I just installed it in v-box again comparing it to the new deepin 20 beta.

Don’t know what has changed in Deepin, but if you add file ~/.config/autostart/welcome.desktop with this contents:

[Desktop Entry]
Exec=eos-welcome
NoDisplay=false
Type=Application
X-GNOME-Autostart-Delay=3
X-GNOME-Autostart-enabled=true

it seems to start. Note that I’m not using Deepin, so this might not be the full answer.

1 Like

That works to make it autostart but there is no app icon in the launcher. It’s not a big deal. I just thought i’d let you know.

Where does current Deepin version look for app launcher .desktop files?
File /usr/share/applications/welcome.desktop should be the one to use as a launcher.

EDIT: The Application Finder has it.

1 Like

Yes i see it but I’m not sure how you add it to the launcher window?
Edit: It’s okay i was able to dock it which is fine. Not used to Deepin so I don’t know how it gets added to the launcher.

1 Like

Couldn’t find an answer to that, sorry.

1 Like

I can’t make any promises since I am new to Linux but let me see if I can make this work on my Garuda-deepin install. I have a few things to take care of first.

2 Likes

I spoke with @librewish try these:

the file should be in either
/etc/xdg/autostart
or
~/.config/autostart

1 Like

@manuel

Change font, I like it!

:+1:

1 Like

Now the texts on the buttons are aligned. That’s why font has changed…

5 Likes

I understand now. Only missing point for translation: drag and drop window title bar :slight_smile: