Weird UX behavior on the Welcome screen since the distro install

Hello guys.


Thats the log. Explanation - Installed EndeavorOS like two months ago. So the first time you enter the OS, you get a welcome screen telling the user stuff to do or they might want to do.

I noticed a bug at that time where the Interface will glitch. It was a pain in my neck so I ignored it expecting to get it fixed in an update.

Its been two months now, and it has not fixed itself. Not sure what to do - tried to screen capture it, but when I start a screenshot tool or screen capture tool, it fixes itself completely.
Here’s a video of completely fine Welcome screen.

This shows screen recorded welcome screen.

This video shows when I recorded the application with the camera on my phone.

A thing to note, sometimes leaving the welcome screen minimized and forgetting it exists fixes the glitchy problem. Not sure how it fixes itself.

Does this count as bug report? :sweat_smile:

happened here aswell, but only first start after fresh install

yes well done :yum:


Dec 06 11:54:35 KnightsDen cinnamon-session[16524]: WARNING: t+0.21299s: Could not read /home/ark/.config/autostart/welcome.desktop: Key file does not have key “Name” in group “Desktop Entry”
Dec 06 11:54:35 KnightsDen cinnamon-session[16524]: WARNING: t+0.21324s: Could not read /home/ark/.config/autostart/wallpaper-once.desktop: Key file does not have key “Name” in group “Desktop Entry”

i am not sure but /home/ark/.config/autostart/welcome.desktop looks strange to me, as welcome uses /etc/xdg/autostart

could you show the content ?

and i cinnamon was causing such issues already before… looks like an issue with compositing ?

This has been a glitch with Cinnamon for a long time now (not EnOS related AFAIK) and is bypassed by turning off desktop effects in Settings. Assuming, of course, that this is CInnamon in use here?

I’m almost sure that it is cinnamon before i switched to bspwm on my bigbeast i had cinnamon with the same behavior.
Now on bspwm no issues and on my littlebeast with i3 also no issues, so i’m pretty sure it is a cinnamon thing.

More precisely it is a Cinnamon WM thing - but I forget what its name is… Maybe I should try switching a Cinnamon build to Compiz? :grin:

and in addition it is not happen in general, i do not see that issue here on nvidia GPU using nouveau drive or Nvidia Drivers

could you share hardware info:
inxi -Ga
and the workaround on cinnamon is to disable effects in settings.
But this is only happen in some configurations.

See also here under “Known issues”:

Sorry guys for the late reply - didn’t boot into Linux for a couple of days :face_with_head_bandage:

The content of welcome.desktop has two line:

[Desktop Entry]

That’s it. And yea, as others pointed out (and I had read it before somewhere), the option in Effect has to be disabled in Cinnamon System Settings.

That worked. To further reiterate, after multiple boot testing I narrowed it down to one setting. You have to turn of Window Effects under Effects in Cinnamon System Settings. No other option in Effects seems to be causing an issue.

I would like to know who should be solving this problem haha. Do the mint guys fix their composition or Endeavor guys figure out whats the glitch here especially with Cinnamon. Its all hypothetical obviously. There is no one party fixing it - ideally you would want Cinnamon devs and Endeavor working out the problem together. I think that would be top 10 anime crossover of the century? Haha

That would take me a couple of weeks to figure out how to swtich lol. No idea what’s Compiz. Just like someone else pointed out they switched to some other Window Manager - I could do that…but then I will spend a week just tweaking the heck out of that and not be productive lol

I thought that would be in that pastebin link? Oh well - let me see. But yea, turning of Window Effects did mitigate the problem.

  Device-1: AMD Baffin [Radeon RX 460/560D / Pro
  vendor: ASUSTeK driver: amdgpu v: kernel bus-ID: 01:00.0
  chip-ID: 1002:67ef class-ID: 0380
  Device-2: AMD Picasso vendor: ASUSTeK driver: amdgpu v: kernel
  bus-ID: 05:00.0 chip-ID: 1002:15d8 class-ID: 0300
  Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo
  bus-ID: 1-4:3 chip-ID: 13d3:56a2 class-ID: 0e02 serial: 0x0001
  Display: x11 server: X.Org driver: loaded: amdgpu,ati
  unloaded: fbdev,modesetting,vesa display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
  s-diag: 582mm (22.9")
  Monitor-1: eDP res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6")
  diag: 395mm (15.5")
  Message: Unable to show advanced data. Required tool glxinfo missing.

There you go. RX 560X and Vega8. Its a laptop, so hybrid graphics. CPU - Ryzen 3550H

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.