Weird font issue

Hello y’all!
Today i wanted to try the cutefish desktop environment, but after installing it and uninstalling it my fonts became weird in my terminal (alacritty).
I can’t find a way to fix it so please help me!
thanks in advance for any answer.

What is the font? Is it still installed? (as in not removed in error).

1 Like

Welcome to the forum. I hope you enjoy your time here.


1 Like

Thanks for the reply.
Here are my fonts settings in the xfce appearance settings :

So i don’t if alacritty is using some special font or if it is the same font used in the rest of the OS that have an issue.

Alacritty defines it’s own font, normally ~/.config/alacritty/alacritty.yml

1 Like

That file doesn’t exists, i also checked the 3 other files listed on the arch wiki and they don’t exit either.

From their gitub:

You can find the default configuration file with documentation for all available fields on the GitHub releases page for each release.

Alacritty doesn’t create the config file for you, but it looks for one in the following locations:

1 Like

i tried creating one at $XDG_CONFIG_HOME/alacritty/alacritty.yml
and put these settings that i grabbed from the arch wiki :

but the issue is still there.

Try another font, list what you have with fc-list. I like fira code and jetbrains both in repo (I think!)

1 Like

What is the result of this command?

fc-match monospace

1 Like


So change monospace to “Noto Sans”

1 Like

It doesn’t work.

Sorry, no quotes my bad :smiley:

1 Like

Try Noto Sans Mono.

1 Like

it doesn’t work with both Noto Sans and Noto Sans Mono

Works for me:

1 Like

What is the result of this command?

fc-match "Noto Sans Mono"

1 Like


I resolved my issue by creating a config file in ~/.config/alacritty/alacritty.yml instead of $XDG_CONFIG_HOME/alacritty/alacritty.yml and setting the police to Noto Sans Mono.
Thanks a lot for your help!