Weird Display Problem

Just ran an update. Mostly saw Haskell stuff in it. Pandoc and such. Restarted EOS, and my laptop display is on, but it’s not displaying anything. I use an LG TV for my main monitor. The laptop display was working just fine until the updates took place and I rebooted the laptop. I can disable the laptop and the backlight goes off. I can turn it back on by enabling again, but no desktop. Nothing. All black. If I overlap the desktops in Displays, I can see the laptop pictures I use, but the laptop display is still black. I’ve tried various settings, but nothing’s working. I’m thinking that an Intel driver might have gotten fubar’d? What should I check into first?

TIA

Here’s what was updated:

[2019-08-02 15:04] [ALPM] upgraded papirus-icon-theme (20190720-1 -> 20190802-1)
[2019-08-02 15:04] [ALPM] upgraded pandoc (2.7.3-18 -> 2.7.3-19)
[2019-08-02 15:04] [ALPM] upgraded lib32-zstd (1.4.1-1 -> 1.4.2-1)
[2019-08-02 15:04] [ALPM] upgraded haskell-zip-archive (0.4.1-12 -> 0.4.1-13)
[2019-08-02 15:04] [ALPM] upgraded haskell-texmath (0.11.2.2-29 -> 0.11.2.2-30)
[2019-08-02 15:04] [ALPM] upgraded haskell-tagsoup (0.14.8-9 -> 0.14.8-10)
[2019-08-02 15:04] [ALPM] upgraded haskell-split (0.2.3.3-19 -> 0.2.3.3-20)
[2019-08-02 15:04] [ALPM] upgraded haskell-skylighting (0.8.2-6 -> 0.8.2-7)
[2019-08-02 15:04] [ALPM] upgraded haskell-skylighting-core (0.8.2-6 -> 0.8.2-7)
[2019-08-02 15:04] [ALPM] upgraded haskell-pandoc-types (1.17.5.4-42 -> 1.17.5.4-43)
[2019-08-02 15:04] [ALPM] upgraded haskell-quickcheck (2.13.2-3 -> 2.13.2-4)
[2019-08-02 15:04] [ALPM] upgraded haskell-splitmix (0.0.2-16 -> 0.0.3-1)
[2019-08-02 15:04] [ALPM] upgraded haskell-juicypixels (3.3.3.1-5 -> 3.3.3.1-6)
[2019-08-02 15:04] [ALPM] upgraded haskell-ipynb (0.1-54 -> 0.1-55)
[2019-08-02 15:04] [ALPM] upgraded haskell-http-client-tls (0.3.5.3-131 -> 0.3.5.3-132)
[2019-08-02 15:04] [ALPM] upgraded haskell-http-client (0.6.4-20 -> 0.6.4-21)
[2019-08-02 15:04] [ALPM] upgraded haskell-streaming-commons (0.2.1.1-6 -> 0.2.1.1-7)
[2019-08-02 15:04] [ALPM] upgraded haskell-http-types (0.12.3-23 -> 0.12.3-24)
[2019-08-02 15:04] [ALPM] upgraded haskell-http (4000.3.14-14 -> 4000.3.14-15)
[2019-08-02 15:04] [ALPM] upgraded haskell-hslua-module-text (0.2.1-16 -> 0.2.1-17)
[2019-08-02 15:04] [ALPM] upgraded haskell-hslua-module-system (0.2.1-7 -> 0.2.1-8)
[2019-08-02 15:04] [ALPM] upgraded haskell-temporary (1.3-36 -> 1.3-37)
[2019-08-02 15:04] [ALPM] upgraded haskell-hslua (1.0.3.1-13 -> 1.0.3.1-14)
[2019-08-02 15:04] [ALPM] upgraded haskell-haddock-library (1.7.0-57 -> 1.7.0-58)
[2019-08-02 15:04] [ALPM] upgraded haskell-glob (0.10.0-17 -> 0.10.0-18)
[2019-08-02 15:04] [ALPM] upgraded haskell-exceptions (0.10.2-10 -> 0.10.2-11)
[2019-08-02 15:04] [ALPM] upgraded haskell-doctemplates (0.2.2.1-87 -> 0.2.2.1-88)
[2019-08-02 15:04] [ALPM] upgraded haskell-data-default (0.7.1.1-31 -> 0.7.1.1-32)
[2019-08-02 15:04] [ALPM] upgraded haskell-data-default-instances-dlist (0.0.1-44 -> 0.0.1-45)
[2019-08-02 15:04] [ALPM] upgraded haskell-connection (0.3.0-14 -> 0.3.0-15)
[2019-08-02 15:04] [ALPM] upgraded haskell-x509-system (1.6.6-94 -> 1.6.6-95)
[2019-08-02 15:04] [ALPM] upgraded haskell-tls (1.4.1-79 -> 1.4.1-80)
[2019-08-02 15:04] [ALPM] upgraded haskell-x509-validation (1.6.11-26 -> 1.6.11-27)
[2019-08-02 15:04] [ALPM] upgraded haskell-x509-store (1.6.7-26 -> 1.6.7-27)
[2019-08-02 15:04] [ALPM] upgraded haskell-x509 (1.7.5-27 -> 1.7.5-28)
[2019-08-02 15:04] [ALPM] upgraded haskell-pem (0.2.4-55 -> 0.2.4-56)
[2019-08-02 15:04] [ALPM] upgraded haskell-cryptonite (0.26-10 -> 0.26-11)
[2019-08-02 15:04] [ALPM] upgraded haskell-socks (0.6.0-11 -> 0.6.0-12)
[2019-08-02 15:04] [ALPM] upgraded haskell-network (2.8.0.0-18 -> 2.8.0.0-19)
[2019-08-02 15:04] [ALPM] upgraded haskell-blaze-html (0.9.1.1-31 -> 0.9.1.1-32)
[2019-08-02 15:04] [ALPM] upgraded haskell-blaze-markup (0.8.2.2-25 -> 0.8.2.2-26)
[2019-08-02 15:04] [ALPM] upgraded haskell-base64-bytestring (1.0.0.2-14 -> 1.0.0.2-15)
[2019-08-02 15:04] [ALPM] upgraded haskell-asn1-parse (0.9.4-109 -> 0.9.4-110)
[2019-08-02 15:04] [ALPM] upgraded haskell-asn1-encoding (0.9.5-98 -> 0.9.5-99)
[2019-08-02 15:04] [ALPM] upgraded haskell-asn1-types (0.3.3-6 -> 0.3.3-7)
[2019-08-02 15:04] [ALPM] upgraded haskell-memory (0.14.18-29 -> 0.14.18-30)
[2019-08-02 15:04] [ALPM] upgraded haskell-hourglass (0.2.12-27 -> 0.2.12-28)
[2019-08-02 15:04] [ALPM] upgraded haskell-ansi-terminal (0.9.1-7 -> 0.9.1-8)
[2019-08-02 15:04] [ALPM] upgraded haskell-colour (2.3.5-11 -> 2.3.5-12)
[2019-08-02 15:04] [ALPM] upgraded haskell-aeson-pretty (0.8.7-82 -> 0.8.7-83)
[2019-08-02 15:04] [ALPM] upgraded haskell-aeson (1.4.4.0-7 -> 1.4.4.0-8)
[2019-08-02 15:04] [ALPM] upgraded haskell-vector (0.12.0.3-13 -> 0.12.0.3-14)
[2019-08-02 15:04] [ALPM] upgraded haskell-unordered-containers (0.2.10.0-15 -> 0.2.10.0-16)
[2019-08-02 15:04] [ALPM] upgraded haskell-time-compat (1.9.2.2-9 -> 1.9.2.2-10)
[2019-08-02 15:04] [ALPM] upgraded haskell-base-orphans (0.8.1-18 -> 0.8.1-19)
[2019-08-02 15:04] [ALPM] upgraded haskell-dlist (0.8.0.6-11 -> 0.8.0.6-12)
[2019-08-02 15:04] [ALPM] upgraded haskell-attoparsec (0.13.2.2-58 -> 0.13.2.2-59)
[2019-08-02 15:04] [ALPM] upgraded grub (2:2.04-1 -> 2:2.04-2)
[2019-08-02 15:04] [ALPM] warning: /etc/default/grub installed as /etc/default/grub.pacnew
[2019-08-02 15:04] [ALPM] upgraded gegl (0.4.16-1 -> 0.4.16-2)
[2019-08-02 15:04] [ALPM] upgraded libspiro (1:0.5.20150702-2 -> 1:20190731-1)

must be something different you have changed … can you paste boot jornal and hardware specs?

Hi @joekamprad. Sorry for the delay in getting back. I’m also sorry I didn’t get the systemlogs, either. I simply reinstalled, and everything is working fine (so far). I’m still getting things set up, but it looks like it might have been a one-off kind of thing. I don’t know. I did install that other quasi-Arch thing…starts with a big green “M” just to see if maybe the laptop display had fried, but it hadn’t. So far, EOS is performing admirably again.

Go figure.