Weird boot issue

Recently I’ve been having issues every time I reboot. System appears to boot fine, no errors that I can see, but when it gets to the login screen / desktop I just get a black screen with a white underscore at the top left corner. Its unresponsive to key presses so I can’t start a terminal session. I have to reboot 3, 4, 5 times with that behavior and then magically it will work again.

I’m using SDDM with autologin and wondering if its related to the keyring. I’ve also tried plasma 6 before switching back to gnome, so could be a package that’s missing?

With GNOME, I would preferably use its default display manager GDM

Perhaps worth to be considered.

1 Like

Changing to GDM seems to have solved it, like I said this happened after I removed the plasma 6 preview (couple weeks ago) so maybe something was missing that SDDM needed. Just odd that it would work sometimes.

I ran systemctl enable gdm -f which recreates the symlink for /etc/systemd/system/display-manager.service.

1 Like

Installing several DE:s next to each other will in many cases produce undesired side-effects, the exact cause of which can be hard to pinpoint .

Also after removing one, it may leave behind some remnants (packages and configs) interfering with the smooth functioning of the system.

If you have removed (uninstalled) KDE Plasma, I would suggest to look into if it has left behind anything.

Check for orphan packages for example and remove them one by one, making sure that it isn’t something you want to keep as optional dependency of other things you have installed on your system.