Weird artifact when using terminal

I just started using i3 (a fresh install), and I often get this weird visual artifact when I start typing in the terminal. It sticks this little box that mirrors the bottom portion of the screen at the top of the terminal window – it generally disappears once I move my mouse a little, but it’s really annoying. Anyone know what might be happening? Not sure what logs to include here. Thanks!

I noticed the same this weekend, same with bspwm and i3wm when I tried installing them next to cinnamon. Never had that problem with i3wm before.

Did not have that problem with qtile wm or xmonad though.

Could be a picom setting dropping shadows? Perhaps try disabling.

Are you using nvidia?

Seems like picom misbehaving. I didn’t face such issues while working on bspwm edition. And from what I know, this is not something that can be perfectly reproduced to debug and fix.

I use i3, and while running picom, I used to sometimes notice weird things going on. I have simply started to use my system without picom, and I haven’t seen such a thing for a few months now.

Removing picom like I did is surely not the right way to debug this problem. Maybe Joe has some idea.

i do not have such issue here, but could for sure be related to picom and gpu driver in use as picom needs different settings in some cases.

#exec --no-startup-id xcompmgr -c -C -t-5 -l-5 -r4.2 -o.55 &
exec --no-startup-id picom -CGb

you could try also using xcompmgr to see if it is the same.

this is used for picom:
-C: Disable shadow effects on panels and docks
-G: Disable shadow effects for application windows and drag-and-drop objects
-b: Run as a background process for a session (e.g. when autostarting for a window manager such as Openbox)

we ship also a picom.conf if the -//options// does not work with more finetunable options:
picom --config ~/.config/picom.conf

One thing to note…You are only at 3% load on CPU but your temps are 68c. That seems very high to me. What are GPU temps like? Overheating can cause graphical glitches on any system.

1 Like

unless it old Macbook :blush: 68c normal

edit. what terminal use?

1 Like

I’m using the xfce terminal.

I tried commenting out the picom line and enabling the xcompmgr line in the i3 config file – but that didn’t make a difference. The artifacts were still popping up.

Incidentally, I had also installed Cinnamon. So I removed Cinnamon, and that seems to have fixed the issue.


you have dex in config what does not work if a full DE is installed aside from i3!

# dex execute .desktop files
# keep in mind that it can cause issues 
# when second to i3 a DE is installed or mixed usage of i3 + xfce4 or GNOME
# in this cases better disable dex and use manual starting apps using xdg/autostart
exec --no-startup-id dex -a -s /etc/xdg/autostart/:~/.config/autostart/


Since you have Cinnamon running. I have seen such an issue if I had conflicting compositors setup to run. I saw something similar a year or so ago when I added picom to my i3 setup, and realized I had both compton and picom setup to run at the same time.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.