Wayland on install?

I just finished installing Endeavour Gnome, it says Window System - Wayland. I thought X11 was default? Did i miss something at install? Thanks!

Wayland is default on gnome 40 and even 3.38 I think.

2 Likes

Aaah ok did not know this, thanks.

1 Like

I did not have a single glitch with Wayland yet. The only thing was that screen sharing on zoom is not supported, but not a big deal. Else great experience on multiple monitors and fractional scaling.

1 Like

I don’t use zoom, i experienced a little jitter but i think it was with the xf86-video-intel which i removed. Any fancy settings i can turn off that will lighthen the “load”? Thanks!

Forgot to mention, I’m using a Intel UHD Graphics 630

the tearfree option is mostly good to do:

sudo nano /etc/X11/xorg.conf.d/20-intel.conf

Section "Device"
  Identifier "Intel Graphics"
  Driver "intel"
  Option "TearFree" "true"
EndSection

Save the file by pressing [Ctrl+x].
3 Likes

I use Intel Xe on my gnome machine.

1 Like

Even 3.36, but I’m not 100% sure.

1 Like

Screen sharing in Zoom works fine, they just choose to hard code it such that it doesn’t work for some systems. Easily fixable by editing the config file:

1 Like

Interesting, didn’t know, will try. I just switched to xorg, but the problem it was screen flickering like a disco ball, not usable. At the end I installed i3wm and screenshared in that session. No problem then.

Haven’t found yet what causes the issue on gnome. Perhaps the Intel Xe graphics driver doesn’t play well with something. Had a similar issue in kde which was fixed by disabling desktop effects. Am very curious to see how it does in Wayland.