Waydroid fails to turn on the Wi-Fi no matter what

I installed Waydroid because I need to install an app that only works on mobile, which is why I then needed a mobile emulator. I found out about Waydroid, and tried to connect to the Wi-Fi but it seems to always fail to do so.

I’ve tried doing everything under the ArchWiki (In this case, I use firewalld) and that didn’t work, I’ve tried re-installing waydroid and doing the same thing, didn’t work, I’ve tried using ufw, didn’t work, and at this point I’m not really sure what to do.

When I say “it doesn’t work”, I mean that, when I try turning on Wi-Fi using the menu at the top of the screen, or in the Settings app, it shows that it’s on, but as soon as you go out of it, and go into it again, it’s off, and I can’t see any avaliable networks.

Waydroid fakes the wifi, so that toggle doesn’t really do anything.

The fake wifi doesn’t work for all apps though, see this open issue here: https://github.com/waydroid/waydroid/issues/619

So is your issue that you can’t reach the internet at all or that the fakewifi isn’t working for a specific app.

I think the issue is that I can’t reach the internet, at least for Google Play Store when I try to log in. I opened the app and clicked Sign In to which it just says “Checking Info” endlessly, which doesn’t allow me to sign into my Google account and install what I need to be installed

I’m using the image without gapps so I have no idea what is happening there, but I bet Google is much more strict with this kinda thing than most other apps. Can you open a browser and see if you can search for something?

Here is a screen shot of me using the default browser to search for “lol” and here you can see that the wifi toggle is not on. I still have connectivity, but some apps don’t like the fact that there is an internet connection, but the wifi toggle is not on.

1 Like

Firstly, ignore the Wi-Fi icon in the Android container. It does nothing.

Secondly, can you load the web browser and go to a random website to see if the internet is working? I’ve had issues with Waydroid’s internet connectivity too, in which firewalld was the culprit, so I thought I’d ask.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.